Launch and Package creating 'old' version of game

Hey,

I’m using the Stylized Kingdom example map, and I’ve added a few custom classes and made a whole bunch of changes.

When I play in PIE mode, everything works great, but if I Launch or Package my game, it’s creating what looks like my game as it was 6 hours ago.

I’ve tried cooking, compiling, building, saving, closing and reopening, and nothing seems to fix it.

Here’s a screenshot of playing in editor after just cooking, building and compiling: http://i.imgur.com/g8GiSfF.jpg

I immediately clicked launch, and got this: http://i.imgur.com/bjH66ME.jpg

As you can see, there’s a lot different. The lighting is different, there’s no monsters, there’s an old testing monster I used previously to the left, the new UI changes haven’t gone though, and the post-process “Drawn on paper” border and texture is back, after I deleted it hours ago.

No idea what’s going on, but it’s super frustrating, as I’d love to package it and show it to someone.

Any ideas?

Thanks.

Exporting it to a different location gives me: http://i.imgur.com/enbm6El.jpg

This is bizarre. There’s no models showing now =/

Howdy Kayar,

Thank you for reporting this issue. Have you used our Materials for Mobile Platforms documentation to check and make sure that all materials meet the mobile criteria? Also, what device would you be using to deploy your project to?

Any additional information would be greatly appreciated.

Thanks and have a great day!

It’s deploying to windows 64 bit. Windows 10 if that makes a difference. It seems like if I export to the same location, it’s ‘rediscovering’ previous assets and taking a shortcut by not generating new ones.

Thank you for the additional information. I believe that the issue is that we currently do not support Windows 10. The highest Windows platform that we do support, at this time, is Windows 8. Would you be able to test this issue on a different computer to see if the same errors are occurring?

Thanks!

It’s not the OS. There’s other people experiencing the same bug. Might as well merge it with this: [BP] Modified inherited components don't reflect modifications in game - Character & Animation - Unreal Engine Forums

“I changed some positions of objects but this won’t show up. It somehow loads an old “version” of the map?”

It’s something to do with blueprint inheritance, I think.

Thanks for the update Kayar. I will talk with Matt, the staff member on the other post, and see if this issue may be related. Judging from the Bug that was placed into database, they seem to be similar. I will keep you updated once I speak with him.

Thanks!

Hey Kayar,

After speaking with Matt, we are fairly certain that these issues are related. In order to confirm, would you be able to share your project with us so that I may be able to further investigate. You can send it to me privately via the forums at https://forums.unrealengine.com/member.php?4890-Sean-Gribbin

Thanks and have a great day!

Hey Kayar,

Since this issue is related the UE-11458, I am going to mark this issue as resolved for tracking purposes. At this time, I am uncertain as to when this fix may be implemented but I will be sure to keep you updated as i see any reports regarding this issue.

Thanks and have a great day!

Same happens to me aswell. After some unreal editor crushes my project start “launch” “3-day ago” version instead current. Im reopen project dozen times, but its not help. Packaged not work, its crushed without any error in log.

Then i start project launcher as admin and its help. Its strange bcoze my project launched and packaged 3-day ago without any admin prev. whatever

Thank you for the information Detech. I will be sure to include that this issue is happening for more then 2 users.

I will also be sure to update you when I know more about this issue.

Thanks!

Hey,

I have a temporary solution that worked for me at least once. Going to test more.

  1. Go to Project Settings > Supported Platforms, then uncheck all the platforms you are not going to use, just leave Windows. Otherwise you will get errors after the third step.
  2. Copy your project to the new directory.
  3. Go to the project directory, then “Saved” and delete all the folders. Always backup everything.
  4. Add the project to your Unreal Launcher.
  5. Voila, it SHOULD package the latest version of your project.

Let me know you if you have any luck!

Hey Sean,

Please tell me you already have a solution :slight_smile: because for such a long time we cannot package or even properly launch our projects… All we get is old versions.

Howdy Nillasky,

Thank you for your comment about this issue. I have looked into our bug database and checked on this report. This bug is slated to be fixed for the 4.8 release of UE4. At this time, I am uncertain as to when this version of UE4 will be released, but I will be sure to keep you updated as I know more.

Thanks!

As a side note:
just did this without #2 & #4 (copy to another directory and manually add) and it works. Thanks!

This morning everything was working. Then this bug started for me.

There’s a few things I made. Could they be linked?

  • include Rama’s victory BP and add a C++ component. (prior to this it was a 100% BP based project
  • cook the game
  • package the game

I did not do many things else this morning. So maybe if you ask me I could find something relevant with your issue.

Anyway, “Bon courage !” Good luck!

Howdy Whitetigle,

Thank you for reporting that you are seeing this issue as well. I went into our bug database and checked on the reported bug. It is currently still open but has been assigned. I will be sure to link this thread to the report, as it may help with the issue.

Thanks!

The temporary solution doesn’t seem to work in 4.9.1. Will there be a fix for this?

Hey FakePlasticTree,

Are you saving your project before you launch it onto your platform? If not, that could be part of the reason why it’s not updating however, I have not yet been able to reproduce this. Each time I’ve made an update on a project, it updates appropriately for each launch on to the device.

Do you have any exact reproduction steps you could provide?

Thanks!

Thank you! Huge help!