"Launch" and "Compile" level error

After getting source code from github I was able to build and lauch Editor and create C++ First Person template project. After compling it I opened it in Editor and it works well. I was able to “play” and “simulate”. But when I trying to “Launch” I am getting this error
“LogPlayLevel:Display: Program.Main: ERROR: Failed to load script DLL: C:\UnrealEngine\Engine\Binaries\DotNet\AutomationScripts\AutomationScripts.Automation.dll: ?? 㤠??? ???㧨?? 䠩? ??? ᡮ??? “AutomationScripts.Automation, Version=, Culture=neutral, PublicKeyToken=null” ??? ??? ?? ?? ???ᨬ??⥩. ??? ?? ???ন???. (?᪫?祭?? ?? HRESULT: 0x80131515)”

Did I forget to build some projects?

Also “Compile” option fails too with:
“Info ERROR: Couldn’t find target rules file for target ‘-FailIfGeneratedCodeChanges’ in rules assembly ‘-FailIfGeneratedCodeChanges_EditorRecompileModuleRules, Version=, Culture=neutral, PublicKeyToken=null’.”

Can you help me please?

I’m having the same exact issue! Would really appreciate help on this.

I think i have same kind of error. My game start and play fine within the editor but if i try to use the launch button i got this :

[2014.04.04-18.37.11:181][379]LogPlayLevel:Display: Program.Main: ERROR: Exception in AutomationTool: Failed to load script DLL: E:\Programs\UnrealEngine-4.0\Engine\Binaries\DotNet\AutomationScripts\AutomationScripts.Automation.dll: Could not load file or assembly 'AutomationScripts.Automation, Version=, Culture=neutral, PublicKeyToken=null' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515)

I have no idea how to make this work…

I’ve had the same issue.
After little debugging of AutomationScripts.Automation.dll, I figured out that the real problem is that AutomationScripts.Automation.dll trying to load plugins for different platforms, and failed when trying to load android.automation.dll on windows platform. So I’ve just remove all content from “\Engine\Binaries\DotNET\AutomationScripts” folder except “AutomationScripts.Automation.dll” and “Win.Automation.dll” . After that game launched successfully!

I got the same error, my problem appeared to be that the DLL files were marked as downloaded untrusted files.

To fix this, right-click each of the DLL files, select “Properties”, and look for a “Security” entry at the bottom of the “General” tab. If there’s a message saying “This file came from another computer and might be blocked to help protect this computer”, click the Unblock button next to it.

Indeed, these DLLs are in the Required<…>.zip files installed as part of the build-from-source process. Well caught!

this is the right one

I may have found a related fix.

Make a new file \Engine\Source\Programs\AutomationToolLauncher\app.config with the following content:

      <loadFromRemoteSources enabled="true"/>

Then rebuild AutomationToolLauncher

where is the exact place of those DLLs?

This solved my problem.