Download

Latencies on VR preview

Hi everyone,

My name is Elisabeth and I’m a french new unreal engine user :slight_smile:
I try to develop a kind of VR game for a movie. So, I test VR scene with unreal. It work very easy but there are latencies (lag) sometimes. The scene is very simple and I have not a too bad configuration : geforce 1080 + I7 6900 + 32go ram. How I can fix this problem ?

Thank you in advance,

Elisabeth

Hi Elisabeth,
Welcome to UE4 for VR! Few pointers for you regarding your problem:

  • Are you running your tests directly in the Editor? The lag may depend on that. You should try to package your game and check the performances there.
  • Did you follow all recommendations for VR optimization listed here: https://docs.unrealengine.com/latest/INT/Platforms/VR/ContentSetup/
  • You can use the GPU profiler (and many other development tools) to check which parts of the rendering pipeline takes most of the time and then optimize it.
  • Recently EPIC run a very interesting webcast on how to optimize a VR experience based on their work with Robo Recall. You can find it here: https://www.youtube.com/watch?v=3Yx9IEOc5s4

Hope this helps.

Cheers,
Marco.

Hi Marco,

Thank you very much for your advices. Yes, I running directly on Editor. I have test to package my game but VR doesn’t work (even if I add “stereo on”). It’s weird…

Hi Elisabeth,

to get the stereo mode working on a packaged game, you can add an Enable HMD node to the Event Begin Play of your level and make sure the Enable option is ticked.

Cheers,
Marco.