Download

Large actors with dynamic shadows

How would I go about optimizing large actors which cause dynamic shadows?

The editor gives me a warning that there is potentially extreme performance issues with the large moving actors in my scene (ships). And tells me to disable dynamic shadows, but this is simply not an option. Without dynamic shadows it looks rediculously ugly.

So, are there any things I should know? Tricks, workarounds, tips on how to make this work as efficinetly as possible, despite the editor warnings?