Landscapes wont work with navigation meshes

Hello , The project I am currently working on uses landscapes as the playable area. This is causing issues with my Ai which functions on other surfaces (bsp’s and static meshes) but won’t recognize move to locations on height-mapped landscapes although move to actor will work and the Ai will chug along happily.is this a known issue or am I just missing something, being dumb?

Any help would be appreciated thanks

Hi KingRagnar,

Unfortunately I have not been able to reproduce this on my end. Can you please post the steps you are taking to have this occur? When you hit P in the viewport to see the navmesh affected area, is it showing up on the landscape? Thank you!

Using a heightmap from geo control 2 we import it into engine, then place a nav mesh bounds volume over the playable area and the green nav mesh visualizer does appear over top of the mesh, but the Ai will remain in place if instructed to move using the move to location blueprint (semi works if use pathfinding is disabled on the move to location node).

Hi KingRagnar,

If you are comfortable with it, can you post a screenshot of your blueprints thus far? I might be able to see something there that could be the culprit. Thank you!

Ok so this is the movement section of several of the Ai.

What happens is the dwarf asks for a formation point location from the sergeant which is a vectoralt text it uses as a offset in relation to the sergeant through move to location. The formation points are set at the beginning of the game by getting the relative offset of the boxes located around the sergeant.

the dwarf movement

The sergeant model

And the Formation points getting added on the sergeant, sorry it’s in three posts didn’t realize how big the pictures were.

Hi KingRagnar,

Have you tried the navmesh on a simple landscape plane without any modifications? From what I can see this should work. I’m going to keep digging in to see if I notice anything but so far it looks like it should be working.

Yes I have tried iti on a flat landscape, the only way I have got it working was through exporting a flat plane then re importing it as a static mesh and using the default auto convex collision. The auto collision worked on simple maps but is only able to support so many levels of complexity, we have thought about importing the map in small chunks through this method but this would be time consuming and finding another method would be helpful.

If you are comfortable with it I’d be more than happy to have a look at your project to see what might be going on. What version of the editor are you building in?

Yeah that would be amazing, currently rebuilding from the ground up to see if we missed something

I’d be happy to do so, if you can post a link to the download here I will grab it and look at what may be occurring.

seems we have fixed the issue, for anyone else who has this issue we had the collision on the terrain as Block all, along with instanced static trees. apparently any static mesh with block all collision touching the nav mesh prevents it from working, (as far as our Ai goes).

Thanks for the help, Awesome to see the amount of responses and the speed of the support.

Hi KingRagnar,

I am happy to hear that you were able to solve your issue! I will mark this as answered for tracking purposes. If you find that this issue persists, feel free to comment here and we will continue to assist!