Landscape too polygonal despite tessellation

Hi everyone,
I’m making a very large landscape (I’ve tried the world composition and it is not the best solution in this case ) and even if I change tessellation LOD close to the camera the landscape still appears like low resolution.
How can I fix this?

Generally, tessellation makes it worse.

I suggest changing the base component size.
Or resizing the x/y of the landscape to get a tighter mesh.

All options CAN affect performance tremendously.

Hi Host, how can I change component size in my landscape?

or what about using displacement?

Sorry buddy, I cant find how can I change component size in my Landscape.

Basically I have to massively use Foliage tool , unless I want to design part of the landscape with Assets… and I have to do it but it’s coming insane in terms of work and efforts
so Foliage… right? I cant see other solutions at the moment to cover this annoying problem

Component size is in the landscape tab at the left.

I’m so sorry buddy… too much UE :rolleyes: … but I cant find it
I mean, here I’m in the landscape mode and I’m using everything about it but I cant find it. I’m using UE 4.25

Quoting Tim Hobson for you:

I’m sorry man but as you can see in my screenshot above there is not drop-down and there “Change COmponent Selection” instead that size.

And then I have above the 3d editor window Manage, Scultp and Paint

Tessellation alone won’t add any details. You need to use world displacement, coupled with some displacement textures for that.

I’ve tried displacement but it is not enough in my case because I really need to craeate lot of details close to camera. Displacement get worse the scene
Unless you can share a better function able to really increase tessellation and make details close to the camera

It may be because of the edit layers.

Perhaps when in use they do not allow you to change the component size.

Start a new level and test what works best.

Then export the various heighmaps of the edit layers one by one and re-crate them…

Yes I’m in edit mode. And my landscape it is not based on a heightmap because I need to edit based on need. I think there is no way to increase details… just keep adding assets

In the picture below…

between Source Control and Content tabs at the top (above viewport, not in it), there’s a tab called “Modes”. That’s where settings for changing the Component Size of the landscape are, in addition to Resolution and several other settings. It’s probably not going to fix the problem of sharp edges in the tesselation though. Have you tried using sculpting tools (in Sculpt tab between Manage and Paint) immediately above viewport and under bigger tabs at the top.