Landscape Tessellation Flickering

Heya,

It seems that for some reason, when I place a landscape and use tessellation / displacement with it, unless I raised the heightmap at that point above 0, it will flicker constantly. Here’s a video demonstration: - YouTube

It’s view dependent, when I recorded I already raised all of the landscape at least somewhat. But it seems that it has to be raised more for glancing angles, hence why you only see 2-3 instances of it there.

Best regards,
Damir H.

Hello DamirH,

Would you mind showing me your material set up for your tessellated and displaced landscape so I can reproduce the issue in a new blank project on my end?

There are known issues with zooming in and out causing landscape components to flicker, but what you are describing seems to be a bit different. I would not be surprise to discover they are related though.

Thank you,

Andrew Hurley

Heya - very simple.

Just place a landscape, don’t modify it and apply that material. Should start flickering like crazy. This is a blank project in 4.11.1

Hello DamirH,

Thank you for the simple reproduction steps. I was able to reproduce this issue in 4.10.4 and 4.11.1 so I have gone ahead and entered a bug report (UE-29262). A simple workaround is to sculpt each component of the landscape, even just a little bit. This will raise it from the perfectly flat surface, and provide some relief from all the flickering.

Once a fix has been implemented, it will be added to the release notes for that upcoming hotfix or major release.

If you have further questions pleas let me know.

Cheers,

Andrew Hurley

Getting this issue also with regular imported planes! Looking forward to the fix :slight_smile:

This issue has been verified as fixed in the 4.12 Preview 1 release. We added options to have landscapes account for the WPO offset by scaling the bounds in the positive and negative Z direction.

Tested in 4.13.2 and 4.14.0 and the issue is still there. Raising the surface does not seem to help.

Can you provide me with a screenshot or steps so I can reproduce this issue on my end?

Thank you,

Andrew Hurley

I tried to use simple material without tessellation but segments still flickering

You might need to modify the bounds of your components. Depending on how large your landscape is, the components off in the distance are fighting to remain relevant in order to render to the screen.

Cheers,

Andrew Hurley

Andrew, you answer very helped. Thank you!

I set Negative and Pozitive ZBounds Extension from -100 to -1 and problem solved.

Can you please explain more widely - why need to adjust this feature manually, how it could get influence for perfomance or quality?

The bounds of any object is used to determine whether or not it gets rendered on the screen based on the size it occupies in screen space. If it is too low, the flickering will occur because it is trying to still render at far away distances, but the bounds is suggesting it should not be visible.

Cheers,

Andrew Hurley

I set Negative and Pozitive ZBounds Extension from -100 to -1 and problem solved.

THIS WORKS GREAT! thanks!

issue appears in 4.18.2 by creating a landscape with default options with a simple material

[edit : I opened the material, closed the window, and now it stopped flickering
I go back to landscape edition and it flickers back again]