Landscape Shadow Seam

Hello,

We’ve recently updated our light settings for the landscape to get dynamic shadows and we came across this error from the shadows. I’ve seen a post about this before, but for some reason I can’t find it.

Heres the examples:

Any tips or links to a fix would be great. The static light resolution is set to 4, would increasing this help at all?
They occur on a slope going down, but this happens elsewhere and we do not see the same issue.

Cheers,

Adam

Hey Ratking01,

If you are using ‘World Composition’ for your landscape and exported from World Machine, I would take a look at the posts below, as it looks to be like your issue.

World Composition - Landscape Seams

I do not think changing the lighting will have an effect on this issue as it appears you landscape seams are offset.

Let me know if this was helpful or if you need further assistance.

Regards,

Andrew Hurley

Cheers Andrew,

I’m afraid this is a straight sculpt from a landscape object within UDK. We haven’t used world machine and world composition is switched off. Heres the landscape settings:

and the world settings:

Also our landscape material:

]#

The Layer blend setup:

We decided to go with a simple system for the material, as we didn’t need anything complicated.

Ignore the alpha blend, that was from a test. It’s all based on LB height blend at the moment.

So I believe I have solved the problem, however, it could rear up again. So don’t hold me to this. I set my lights (Direction light and skylight) to moveable and this has apparently solved the issue. I’m not sure why this solved the issue, but if anyone has the answer that would be much appreciated.

Cheers,

Adam

Hey Adam,

Well, the only thing I could guess being the culprit was the, static lighting resolution set to 4.0 on your landscape actor. Since you changed your light sources to moveable, everything in your scene is using dynamic lighting and shadows. This means the ‘Static Lighting Resolution’ is ignored since there are not static lights or shadows being baked into your landscape.

To test this theory, set your Directional Light to Stationary and set the ‘Static Lighting Resolution’ to 1.0 and see what happens. Then set it to 4.0 again, rebuild your lighting and compare.

Cheers,

Andrew Hurley

I simply rotated my Directional Light back and forth and the seams went away. I think I got lucky.