Landscape Normals aren't smooth


So I have this problem right now with my landscape. The normals aren’t being smoothed properly, so it looks kind of low poly. It’s not that the surface has no smoothing applied, the triangles do look a little bit smooth around the edges, but it doesn’t extend across the entire triangle surface.

As you can see here the problem is very noticeable. Although it largely disappears when you move further away.
(notice how the edges of the triangles has som very small smoothing that doesn’t cover the entire surface)

I even tried to double the landscape component resolution but it had barely helped at all.

(The same location but with doubled component resolution)

I did have tessellation enabled and at first I thought that might be the problem, but I have already tried removing it and all the screenshots shown here are taken with tessellation turned of, so I know that’s not the problem.

Does anyone have any ideas what might be causing this problem?
Any help is much appreciated and I look forward to reading your replies! :smiley:

Also if I some part wasn’t clear or I broke some etiquette this forum has pleas let me know :slight_smile:

That is not normals, they are fine. It is shadow acne.