Download

Landscape new non-destructive edit-layers material problem

Hi there
Using the new non-destructive layers for landscape editing, sculpt works very fine but paint does not : all the layers are kind of “mixed” together.
Say you have 2 materials (grass and rock) in a layerblended material, then 2 non-destructive layers, you fill the first one of grass, and paint the second one with rock, the rocks and grass will be “mixed”, I mean the painted rocks won’t be more than about 50% opacity I guess…
Only decresaing the alpha of the “grass” layer to say 0.01 will show me “correctly” the two materials, but that wont be a good way to work with multiples editlayers.
Is there a way to have the top layer totally replacing underlying layers where it is painted ?
Tried this on 4.23 and 4.24, same problem.
The Epic youtube presentation does not seem to have this problem I just don’t understand. Many thanks

WeightBlend Or HeightBlend?

heightblend … does it makes a difference ?

Probably not.

The issue may be your landscape material. Or the fact that the material used in the demonstration was different (not using landscape layer blends).
Unfortunately we cannot know until they update content examples other then by trial and error.

Shot in the dark, but with two layers, try setting the alpha to .5 on each to see if the paint starts blending correctly.
If that’s the case, then with 3 layers you get .33333, with 4 .25 and so on.

I haven’t gotten to try out the system properly yet…

ok many thanks for your time answering me
Maybe I was too in a rush using those new improvments
I’ll fall back to the old fashioned way and keep an eye on it
Many thanks again