Landscape material is black.

hello, i’ve tried to make a landscape material and it’s not working

the preview of the material works fine, so does it when i apply it to a static mesh. but once i apply it to a landscape it goes black. no idea what this could be since im new to ue4

also i don’t have an usage option to set it for landscape.

the viewport picture is a static mesh and a landscape next to each other with the same material

Most likely you just forgot to add name to your material layers. It says None, where a proper name should be on landscape blend node. Additionally, you have to add those layers in landscape tools.

1 Like

Hi, i have have the same issue too, but i have proper names on each node, so can you help me figure why?

I just started using UE4.13 today

  1. turn off height blending on the “Landscape Layer Blend” nodes, there’s a lot of misinformation about height blending and you don’t need it (although you have set it up correctly).
  2. go into the landscape editor, go to the “paint” tab, add layer infos to your layers and then right-click one and choose “fill”. After that you can paint normally.
  3. set your landscape material to “opaque” instead of “masked” (leave the visibility mask node connected to opacity mask output, even though it grays out), and ignore any instructions in tutorials about setting up a separate “hole material”. Landscape actually manages that itself now, as long as you have the visibility mask node in the material it will work.

After i did all the changes that you list, its still not working, after i fill layer with one of the texture, my landscape just have one texture, i could paint it, but the painted texture will cover up the filled texture.

I got it to work, thanks alot

How did you end up fixing it? I have the exact same problem as you and I couldn’t figure out the above step 2.
When I go to the “Target Layers”, do I apply a Weight-blended layer info, or non-weight blended? Additionally, adding the layer info appears to leave the material as mostly blank.
What steps did you take to fix it?

All of my target layers appear blank:

You add the first option layer, i forgot which one, and then just fill your landscape with one of the layer, then go to paint, choose the smooth brush for the other colors

I recently had this problem with most materials that I imported from the UE marketplace. To fix it, I:

  1. Created the landscape with the
    desired material assigned to it. (The landscape would show up shiny and black).
  2. Went
    to the “Target Layers” section under
    “Paint” (both within the landscape
  3. Each layer had “None” assigned
    to it, even though each layer was
    connected in the Material blueprint.
    So I clicked each “None” and
    assigned the Layerinfo that appeared
    beneath “None.” Voila!
1 Like