Landscape material bug, major black splotches despite having alpha-blend

Okay, first off, information that may or may not be relevant to the issue.

I am running on Windows 7 64 bit, 12GB RAM, Intel i7 3610 QM CPU @ 2.30GHz, nVidia geforce 660M GTX 2GB, and it’s a laptop.

When I have more than one layer on my material, I get these black splothches every where. I have looked up and searched all I possibly could, within reason, trying to resolve the issue but have so far failed. I will attach my material and a few screen shots. I have indeed tried setting one of the layers (my grass layer) to LB_AlphaBlend (I have tried setting all of the layers to this as well, and I have also tried making non weight-based layer infos), but it didn’t fix anything. I have also tried using the Layer Weight node system in place of the Layer Blend node system, but I got the same result. It seems to be linked to normal maps. Another issue I have is if I have more than one material per landscape material, and then start painting on my landscape, the landscape component “chunk” turns completely black until I paint it over with the base layer and then repaint the other details I want. This is annoying, but I can work past it. It is there whether I have normal maps set up in my material or not. With the addition of normal maps, I get the black splotches I originally made this bug report for. The splotches are dynamic as well, usually taking some of the contours of the terrain and infinitely repeating on themselves.

I’m seriously going crazy over this, any help would be greatly appreciated.


I may have FINALLY found the issue. I deleted the sky light from my level and the black splotches shown in the third picture disappear. The ones in the second pic appear to be a result of my method if implementing detail maps over the cliffs, so all that is left is to fix that, but it isn’t a bug (at least I don’t think it is). So, my issue has been resolved, but my answer has also produced another question, the question being “why does having a sky light cause that black splotch bug?” The answer to that isn’t meaningful to me, but perhaps it would be for somebody else. Anyway, I’m glad to finally be rid of this issue finally.