Landscape Looks jagged and materials are not smooth

SO I am noticing that my landscapes look low poly. I am actually Okay with that, except that when I do material paint, it seems to only paint along vertices.edges and not as a whole.

IS there something I did I wrong when I CREATED the landscape?

I would hate to have to recreate the entire map, but if that’s needs to be done i would rather do it now, then later on. Is ther a way to make the blends less triangular?

I noticed this only happens on cliff edges and walls where it looks like the landscape is being “stretched”. is that how sculpt works? it stretched the landscape vertices?

if you look at the attached images the flat areas blend perfectly, but the cliff edges are weird…

It makes it very hard to paint to, i have to hit the perfect spot or it wont paint…


Use retopology tool, and make cliffs less steep a bit, use brush/mesh if you need super steep cliffs.

Thank you for your help! Where do i find the brush/mesh?

Brush/mesh as in either go into brushes as in geometry brushes, and mesh as in open your 3d modeller of choice. I would reccomend retopology tool instead, though, because its easy.

it seems retop didnt work for me…

It started crushing the landscape… i tried with different falloffs and sizes…

Ohhh Well I am using the unreal landscape creation. I am not using outside 3d meshes for landscape. Should I be doing that instead?

Also I have a feeling I went too conservative on the landscape specs when i created it.

Right now it says the following:
Component Resolution: 64 x 64
Component count :64
Subsections 1 x 1
Resolutions : 505 x 505
Component Count 64
Overall Resolution 505x 505

I am thinking i made it with too little detail from the get go…

The engine will also aggresively simplify the landscape when you’re running at low frame rates. Press Ctrl-Shift-H to show frame rates, and if it’s under 30, that’s likely contributing to your problem.

try using the Landscape smoothing brush, but I think your landscape is low detailed. You should use a landscape with more polygons.

Use tesselation, don’t increase resolution of the landscape for that one area. The settings you chose aren’t conservative, they’re mid-range. It looks like the cliffs weren’t sculpted correctly or using correct tools. You need to apply smoothing to remove the wide, jagged cuts in the cliffsides. If it’s not working, then it needs more polygons / vertices / edges.

Im getting about 120 FPS right now… so the FPS is not low at all

Ive smoothed this landscape smoother than a babys bottom LOL how would I get a landscape with more detail? I have no idea what to do to get that.

Yea as previously stated smoothing isn’t helping. How would I add more vertices/polys? the only tool i was using was sculpt with falloff around .5 power around .2

UPDATE: Well I think I just had to keep smoothing more… I am getting rid of alot of the polygon edge look. What I had to do was smooth and keep adjusting the Filter kernel. Its still not perfect as I was imagining I can get. Maybe next time around ill pay closer attention to the landscape creation.

If someone can help me figure out how to get more vertices/polys that would be amazing!