Landscape Lightmap - Border not lit by Sky Light

I have a level with two Landscapes. Unfortunatly when I build the lighting, I get an unlit border on one of the landscapes. It doesnt seem to get any light from the sky light in the area close to the other landscape which surrounds it.
Has anyone experienced a similar problem? Any Idea how to fix this?

Hi Fizz,

I’m not seeing the same results on my end with 4.7.3, so just for the sake of clarity I want to make sure of a few things.

  • Is this a tiled landscape using World Composition or two landscapes that have just been lined next to each other?
  • Does this happen only in this project or is it any project/map that this is happening with?
  • From the looks it looks like Skylight is working because the lighter shadows are on both landscape. Is there supposed to be a normal map for the other landscape (close one to the top of the image) that runs across both landscapes? The one on top doesn’t appear to be using the same material that I can see.
  • If you use just a basic material for both using just a constant value of 1 plugged into the base color, do you see the same issue?
  • Is this a stationary Directional light source? Default settings?
  • When you build lighting, are you using a lightmass importance volume around your landscapes along with Production Quality lighting?

Let me know, and I’ll be glad to help look into this further.



Hey Tim,

Its two landscape placed next to each other.
I tried it in another level and I was able to reproduce the Issue. In fact, the black spots now not just appear on the borders but all across the inner Landscape and also on the borders of the surrounding Landscape.

To clarify, here is what I did:

  1. I create a high resolution landscape
  2. I duplicated it and changed the Component Size of the duplicated Landscape to a lower resolution. For the Resize Mode I choose Resample to maintain its size.
  3. I deleteed the inner four Components of the LowRes Landscape and the outer Components of the HighRes Landscape, so nothing would overlap.
  4. I baked the lighting

For me the result looks like the deleted Components are still casting a shadow, although they are definitly not there anymore. I was testing with 4.7.3 by the way.

Anyway this Issue isn’t really critical to me anymore as I realized that I have the option to set the LOD of each Component of a Landscape individually. That seems like a much cleaner Method to optimize the overall landscape Resolution.



Hi Fabian,

Thanks for the details!

I’ve actually been able to reproduce this with some larger landscapes but not with smaller ones. I’m in the process of narrowing down some of the more specific cases that is causing this to appear.

As a point of reference I can see this clearly with the static meshes placed along that line for any parts of the landscape or mesh that go below the resampled landscape.

I’ll update with a JIRA ticket once I’ve narrowed it down a bit.