Download

Landscape Ignores Light Sources?

Title says it all. My landscape is ignoring light sources for the most part - just a weird part of the light actually works. Picture:

As you can see, the spotlight does hit the landscape and a part of that landscape (at the right side of the spotlight) does illuminate. It’s a very weird behavior. Force no precomputed lighting is on, but I cannot rebuild the lighting to fix it - it’s grayed out. Any suggestions?

-What happens when you set your light to moveable?
-have you already pressed the play button (sometimes it will solve a light problem) :slight_smile:
-does this also happen in the example/default map? (add a landscape - assign a material - add a light)
-what happens when you move the landscape a little bit (e.g some units up/down)

I don’t think you can move the landscape. If you can, don’t move the landscapes. Very weird bugs start happening.

As I can see from attached image, that light affects landscape on the right side.

So…

First of all, for a spot light try to set “inner cone angle” more than 0, set bigger “attent. radius”, bigger “intensity”, or even uncheck “inverse squared falloff”.

Then also try to build lightning in that level.

-Nothing changes.
-Problem persists even when playing.
-Changed the terrain + spotlight to the example map - same thing.
-Nothing - problem persists.

You can move the landscape, but I haven’t, so that’s not the case.

Tried all of that - no luck. Build lighting is grayed out like I said - can’t rebuild it.

Show your lanscape material

bd38607f135ea6313825c182e1f00c9c689c0cb1.png

There it is.

Ok. Did you tried to unpin everything from normal in material and check results in game?

I fixed it. I had a ‘0’ plugged to my normal maps for layers 1-3, which is a black color. Changed it to a three-constant - 0.1, 0.1, 1.0 - now it’s a blue color, the way normal maps are supposed to be, and lighting affects the landscape. It’s weird, that if it’s a black color plgged in the normal map slot, some of the light source still shows up and some doesn’t however.

1 Like

cheers this fixed my issue