Download

Landscape Grass Type not showing.

Hi everyone,

I had a landscape which was working really great. I tried to add some new grass types, and the first main grass types started to disappear. Is there a maximum amount of landscape grass types?

http://i.imgur.com/wGo6RHSm.png

Thanks,

I don’t think so but I will forward this to Jack Porter who should know.

In the meantime, can you try typing ‘grass.FlushCache’ in the console and then wait a while for all of the grass maps to re generate. I did see some occasional wonkyness with grass map rendering at one point but that bug was fixed. It is possible you have found a new issue. Let me know if flushing it helps.

I have the same problem:

It happens if you have more than 4 or 5 grass types and at least one of them has a 1 connected to it.

Is it just a 1, what about if you instead use another landscape layer plus a large scalar parameter?

Here is an empty project with a new material and seven layers : https://drive.google.com/file/d/0B1Q_UZXlKbU9VzZTRmpuNlVqSFE/view?usp=sharing

it doesn’t work either here (don’t forget to add startercontent and a landscape)

Did you still use a 1 or what did you use to define the value? So far nobody has said whether or not they tried that.

So here is the grass node:

http://i.imgur.com/7uDTM2dm.png

Grass01 is a cube
Grass02 is a cone
Grass03 is a cylinder
Grass04 is capsule
Grass05 is a pipe
Grass06 is a pyramid
Grass07 is a torus

http://i.imgur.com/BihbVghm.jpg

Sorry for the bump of this old thread but I have the same problem.
There was an old post explaining that there is a limit of number of layer and the solution was to edit the LandscapeGrassWeight.usf file but I can’t find this post anymore and lost the code because of engine update. Did anyone remember this code?