Download

Landscape Goes to standard grey checkered material?

I have a total of 4 layers.

One base layer weight that is a grass material
A height that is sand (used on beach)
A rock material i am using for cliff faces (height)
And a tile/grass material that gives me a rock path (tried both height and weight on this one)

When i have the rock and tile in same area it greys out
Best documents i found said you couldnt have more than 3 height materials in one area…

I can leave the grass and put in the rock and sand and works.
I can have just the tile, grass and sand

But if i set the tile to weight or height and put them in same area it goes into that grey (which i understand is basically the error message that there is too much)

What can I do to fix this? what causes it exactly?

Change all you texture sample setting in Material Editor: sampler sourse→shared:warp

Appreicate it. No idea what that does or why it works but after quite bit time compiling shaders when I made the first mark it went back to that checkered pattern and I was worried…but then it went to exactly what i wanted.

THANK YOU!
(should i always use that setting on landscape materials? On anything else?)

where the hell is that option?

open the material, click on a sampler and in the details panel, in the submenu called the material expression texture sample. click on sampler source and change to shared: wrap

Edit for attatchment

There’s a limit to the number of samplers in landscape layers / materials, which is 16 (the same as other materials, at least most I guess). It doesn’t show in stats, according to the doc page on basic landscape setup.

shared wrap gets around that limitation.