Landscape deforming in Standalone Game

Heya all.
I’ve got a weird bug on my hands. Landscape gets deformed when I have a couple of pawns near me on a specific piece of landscape (seems like lod gets triggered but partially). It does not happen when my character is alone or if its PIE, it happens only on Standalone Game with multiple actors near the player.

“Deformation” dissapears after I kill the actors or move them out of that area and it doesn’t reappear afterwards.

I’ve tried rebuilding lighting, resampling the terrain via change component tool but the issue remains. All of the Landscape settings are default except Overlap Events which are on. Any ideas?

Very interesting.
assuming you can play in editor, activate slomo .1 eject from the player and take a few screen grabs of the situation.
try and select the landscape to see if that’s really it.
There should be some underlying reason for it…

Thats the thing, it does not occur in play in editor, only in standalone. It sometimes happen when I build lighting and it disappears soon afterwards. I’ve used the wireframe view and its definitely the mesh getting skewed somehow, it gets back to normal after a few secs.

Now that I’ve got a better look seems like LOD1 is being triggered for some reason, but I’ve tried setting MaxLOD to 0 and it still happens.

EDIT: Here’s how it looks from debug camera:

P.S. Terrain shows no lod no matter how far the camera is.

Just a suggestion…
if your level is finalized, ditch the landscape.
generate an impostor (copy level to a level with world comp, force the lod generation with no % of fidelity loss).
bring the mesh into the level you package, delete the terrain.

Obviously it’s not the same as finding the bug, but you should be able to package/release this way…

Interesting idea. As a temporary fix I’ve disabled texture streaming and the bug is no more. r.Streaming.FullyLoadUsedTextures makes the pop shorter quite considerably but there is still a pop.

This is still happening in standalone with texture streaming on BUT it does not happen in the packaged build. I’ve got my texture streaming back yay!