Landscape and tesselation display bug

Today I tryed to use tesselation on a landscape, but I obtain strange result:

Here is my material:


Hello Freebios,

I set up a test to see If I could recreate the same issue.

Steps to Reproduce :

1.) Create a new Landscape
2.) Create a material, similar to yours, with tessellation and world displacement.
3.) Apply this material to the landscape and build lighting.

Here are my results with this material setup.

I am not seeing the flickering that you are. I have some more information I would like to gather from you in order to narrow down what could be causing this.

1.) Can you link me a copy of your DxDiag?
2.) Does this happen in another project in 4.9?
3.) Does this happen with 4.8 or 4.10?

After I have this information I should be able to narrow this issue down.


1)Here is my dxDiag

2)In fact it’s my first time using Tessellation and landscape together !

3)I tryed importing the same project in 4.10 preview 2 and still having the same bug

Did you tried to unselect your landscape in editor? because it start flickering only when i unselect it or when I hit the Play button. I tried with several parameters for the landscape but it happen the same thing even with the default values.

Have a nice week end :wink:


Here is a little update, the same bug seem to appear with classic meshes. I created a cube and applied my material and when I stand really close or far of it, the cube start to flash like this:

I did select and deselect the landscape. I still was unable to see the flickering.

If you would link me a test project where this is happening I will attempt to reproduce this issue on my end.

Here is my project folder:

So I have narrowed down your problem to that of the intensity of your World Displacement. You were multiplying your texture coordinate by ten and then multiplying that again by the VertexNormalWS.

I set the value down to 1.5. This solves the issue. You still may see a flicker or transition when rotating the camera very fast but it only happens at the edge of the screen at a very far off value.

I believe what you are attempting to do is increase the intensity of the material so that the rocks are deeper. What can happen is that your displacement will exceed the bounds of your mesh, or in this case your landscape.

I am linking you our documentation on tessellation and world displacement.

You may be able to keep these setting for your material just increase the bounds for the landscape. You will have to tweak these settings to produce what you want.


First thanks for your help, there is a little problem with the website, I can’t see your answer. I read it in email.

Everything works with meshes, but I didn’t find the Scale Bound on the landscape.

One last thing, sometimes the landscape looses it relief like this:

When I select the landscape we can see the shape of it:

But in fact the landscape is flat:

Thanks again for your help :slight_smile:

It looks like this only happens when you are below the landscape. I would stay on the side of the landscape that the material is being called on. As a rule landscape is one sided. For instance, if you made a hole in your landscape the backside would be transparent and would render only what is facing the camera on the top side. I may have goofed on the landscape. The landscape uses its own default bounds and are not adjustable in the same way that static mesh’s are.

I found the problem, if the material has “crack free displacement” checked the landscape will be flat, so we can’t use the same material for meshes (if we don’t want a cube with hole on edge for example) and landscape.

And I’d like to know if is there any workaround to have bigger relief on the landscape? Because if I can’t multiply my texture coordinate over ~2 without getting flickering and if I can’t change the Scale bound I can’t really reproduce a rock effect for example.

Thank you for your time!