Known issues with the Fab (Alpha) plugin

Fab is still in the early alpha phases, and like with any product, we have some issues. We want to encourage you to report any issues you encounter and suggest any valuable features you are missing.

Some of the high-visibility known issues are listed below:


Thumbnails appear as bricks when adding a personal referenced pack.

This will be fixed in one of the next releases, however for now there is a Pro-tip that can fix this: You just need to highlight all of the assets and drag them around (no need to place them in the scene).

There are some quality issues with Unreal Engine assets, and in some cases, the quality level looks completely degraded.

This is a known issue that is being worked on, but there is a solution. Anything that is available on the Unreal Engine Marketplace and UEFN is granted under the same purchase. This means that if you’d like to get the original Uassets (Unreal Engine files) into your project you just have to import them from Unreal. Follow this guide to do so.

Why do I have one mesh per folder when I am using Personal referenced?

Our goal with referenced content is to give you complete control over the file structure and naming just like regular meshes. However, we are not there yet. For now there are known limitations, moving files around and renaming them are some of these.

There is also a known limitation when adding a Pack to a project, where it’s located in a single folder, but with a subfolder for each asset. Pro-tip: all you need to do is set a static mesh filter in the content browser, and you’ll be able to see the individual files. Click here for the guide.

I added an asset from Fab to my project, and it takes a very long time to load/cook.

This is also a known issue we are working through. The good news is that this will only happen the first time you drag an asset onto your project

I purchased a 3D model, but the collision doesn’t seem to work.

I purchased a 3D model, but I can’t destroy it with a pickaxe.

Everything purchased on the Fab plugin in UEFN is currently a 3D mesh. However, there is a way to set the mesh to be destructible in UEFN. Follow this guide to easily transition your mesh into a building prop.

I have bought a personal license for an unreal pack, to receive the source assets, but I can’t seem to be able to add it to my project.

In order to add source Unreal assets to your project you have two options.

  1. You can navigate to the individual asset product page within the Fab plugin, and from there add to your content browser. This will create a folder for the asset as an unreal file you can edit, and not the referenced version.
  2. You can also add content through the tools already provided in Unreal Engine. Because all Fab pack purchases also grant you access to the item in Unreal Marketplace, you can use the migration tool to copy assets into a UEFN project. Here’s a guide to add a pack from Unreal Engine Marketplace and then follow these easy steps to get it into UEFN.

Last updated: April 27, 2023

o/
:exclamation:Major: Fab is constantly crashing UEFN. 100% repro

Steps:

  1. Launch UEFN
  2. Load into Your project (very small, ~600 actors)
  3. Open FAB after everything loads
  4. Type something into FAB search bar
  • or start browsing some categories on LHS
  1. Crash

Expected beh: Fab doesnt crash UEFN allowing for interactions with it
Platform: PC, Windows 11 Home x64 22H2

Project does not contain any FAB assets. Happens also after some time when working and doing same steps. Happens also in e.g. Detonation Example project just after download
Logs attached from my project, based on fresh launch route steps:
UnrealEditorFortnite.log (1.2 MB)

2 Likes

Thanks for the detailed error report!
I’ll forward this to our team and will let you know when it’s been fixed.

FYI we’re still looking in to this and we may contact you for further information. For future reference (and for anyone who happens to stumble upon this topic), here’s the preferred way of submitting bugs.

Failed to download/load Referenced Content uefn is the error I keep getting I have a bunch of content i purchased and downloaded into refrenced content. now when i open the project it fails to load the assets and ends up not being able to redownload them. I’m rather upset I cannot use What I paid For.

@Lupercal8796 Thank you for your report! Can you please re-post using the “New Issue” option on the Issues and Bug Reporting forums ? Posts with this feature are connected directly into our development team so we can quickly get to them!
For more information, such as how to get the reference ID, please check out the article here: Using the Creative and UEFN Bug Reporting Form

The other issue i have come across, that once imported Fab content is on your island and in your reference content it is causing the error, the world contains invalid actors. Clicking the error repair button does not do anything, the only thing that you can do is remove fab content, this can only be done by removing the referenced content in your project folder. ( It does not show up anymore in the editor ) Once this has been deleted and you have reopened your project, all items that disappeared, like fortnite creative assets and or even the island settings, are all back. But this means that for some people, we can not use Fab content cause this will crash the island ( no matter how many island you try make, as soon as it gets introduced with Fab content it is screwed )

I’m having the same issue. Also I imported fab content as referenced content to my project, It was useable at the beginning but when I saved then closed and reopened the project, the fab referenced content folder was gone, and pressing ctrl B on an asset that I had dragged in my level won’t show me where the static mesh asset is at in my folders. It’s like it’s still referenced properly with no errors but it doesn’t exist in my content drawer.

1 Like

I just realised most of my devices have disappeared and I’m facing the exact same issues as Tinkerbell1980. I think the only workaround right now is importing to unreal and exporting the specific assets that we need which isn’t ideal at all.

1 Like

I have not tried that yet, cause the packs in Fab are more expensive to have them in the vault in unreal engine, which is absolute bollocks! I am seeing now so many people having this bug and so many of their project having become useless, so many reports made, and literally nobody is listening.

Have you all tried again after the latest update? We made a few changes that may help address these issues. If you’re still encountering them, we’d like to know - thanks!

1 Like

Hi there,

Yes i still have encountered that error that says the world contains invalid actors, just two days ago.
I can not use fab content!

Really hope this can get sorted, otherwise i paid for nothing.

1 Like