Knowledge Base: Increase the Number of Modules Loaded When Attaching the Debugger

Increase the Number of Modules Loaded When Attaching the Debugger
Article written by Martin S
Debuggers on Windows are limited to loading the symbols for 500 modules when attaching to a running process. Unreal based pr…

https://dev.epicgames.com/community/learning/knowledge-base/l740/unreal-engine-increase-the-number-of-modules-loaded-when-attaching-the-debugger

23 Likes

wow, Finally I found solution, Thanks a Lot !

Thank you very much. Your reply solved the problem. This was one of the worst problems in my development life that was very difficult to determine the cause.

Thank you so much! It works for me!

OMG, I had no idea how to even describe this problem to find a solution. Just ran into this thread totally on accident. Thank you!

  1. Press the Windows key + R to open the Run dialog box.
  2. Type “regedit” and press Enter to open the Registry Editor.
  3. In the Registry Editor, navigate to “HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager”.
  4. Right-click on the “Session Manager” key and select New → DWORD (32-bit) Value.
  5. Name the new value “DebuggerMaxModuleMsgs”.
  6. Double-click on the new value to open the Edit DWORD (32-bit) Value dialog box.
  7. In the Value data field, enter the value “2048” and click OK.
  8. Close the Registry Editor and restart your computer for the changes to take effect.
7 Likes

fwiw, this did not help me at all :frowning:

Hi, try to select a solution configuration “Debug Game” in VS.
image

Looks like the current solutions don’t work anymore. Anyone else still haveing this issue with Rider?

Somehow I recently had to redo this change in the registry + reboot my machine, and all the modules were properly loading again in VS :slight_smile:

Just a small note that could help others: after you created the registry key, you must reboot the machine.

The Windows kernel read the key only on startup. This was explained in the Microsoft KB 953490: https://web.archive.org/web/20100121111745/http://support.microsoft.com/kb/953490

Oh, it’s work, thank very much