Kitbash3D - Assets not appearing in editor of own project

Hello - I’ve imported a Kitbash3D kit into UE5 as content for my project but when I drag the actors into the scene/editor I get only their edit arrows - no mesh, no nothing. When I open the Kitbash project that contains all the actors, the actors load fine. Can anyone tell me where I am going wrong please?


Update: I’ve tried to upload assets from a different kit into another kit’s project and they also don’t load in that kit…is there a setting I need to select or a set I’ve missed when importing my kitbash3D models?

Did you try migrating the assets?

I’ve got the same issue. Actor assets do not load when dragged into the viewport in UE5. I am using the new neo San Fran kitbash 3D kit. The kit has been imported into the project per the instructions on kit import docs into UE on the kitbash 3D site.

These Assets can be quite heavy to load. Sometimes UE just needs some time to process all of them. There should be a loading bar on the bottom right corner. But as @ClockworkOcean suggested. Right click on your asset in the other project → asset action → migrate → choose your CONTENT Folder.

Not sure what you mean. What other project?

When you download the kit, it’s a project. You can migrate everything from that project to your main project.

I do agree though, I don’t think the kitbash stuff is native UE. I always lose the content browser thumbnails.

The Neo San Francisco kit doesn’t appear to ship with a project file. The zip files give you 4 folders: actors, geometrics, materials and textures, when unzipped. Doesn’t appear to be a project file anywhere. But double checking.

Ooh… they’ve changed their MO…

Yes it seems to be the case.

So there’s no mystery… I emailed Kitbash3D support and the main folder for the kitbash3D assets I made said 2K in part of its spelling. Removed this from the folder name spelling and everything loads. Moral of the story I guess is don’t put numerals in content main folder names. :slight_smile:

Having the same problem here, invisible actors and have tried everything suggested above and its still not working. Bought the cyberpunk kit and the actors were invisible. I took the numbers out of the file name and that seemed to fix it. However, with the new dieselpunk kit nothing I can do has made the actors visible. I never had any number anywhere on the file names this time. (Content folder with the four folders in it is named “Dieselpunk”). Copy and pasted the folder directly into the content folder for the project in file explorer and still invisible actors. Gemoetry, etc., all there just no actors. Even tried opening the content in another version of the engine and migrating the stuff over to a 5.0 and still nothing. Actors are invisible in all versions. Out of ideas. Big fan of KitBash and have most of their stuff. This is the first time I have been really disappointed with my last few purchases and trying to get them to work in 5.0. Any other ideas please???

having the same trouble. finally solved it. stupidly simple. Just keep the exact folder name and structure. /content/KB3D/KB3D_Neo***, do not remove KB3D folder before KB3D_Neo***. It worked for me.

Hey! I’ve got now the same problem, do you solve it?

1 Like

Just keep the exact folder name and structure. /content/KB3D/KB3D_Neo***, do not remove KB3D folder before KB3D_Neo***. It worked for me.

Did you figure this out? I have the cyberpunk assets and they show in the content broswer. But when I drag them into the scene, they are invisible. How did you solve this issue?


“For Unreal | After choosing unreal as a software, you have the option of downloading the texture in 2k or 4k.
Both, the kit and the texture come in a separate folder. After downloading them, open the folder name uasset4k and drag it into the other folder name kb3d_cyberpunk.unreal.native. Rename this Main folder as “ cyberpunk “ lower case.
Now in it You should have the : actor,geo,mat,text.
Now drag this main folder into your UE4 or UE5 project inside of the folder name “content” .
Open your project in unreal,
Right click on the folder “cyberpunk “ scroll down a choose “validate assets in folder” after doing this everything should be connected together.”

1 Like