Download

Keeping foliage.MinimumScreenSize set for packaged version

Please would someone be able to advise me on this issue?

For my dissertation, I’ve been working on a recreation of Hokusai’s ‘Lake Suwa in Shinano Province’ in UE4. Things have gone very well, but I’ve hit a snag at the last moment – foliage culling. The distance/size that I am trying to render at is such that setting cull distance in the foliage editor to a min and max of 0 does not help – in order to have foliage in the distance appear, ‘foliage.MinimumScreenSize 0’ must be typed in console.

However, this is only a temporary fix, needing re-doing on each start, and not carried through packaging. I was able to find a topic at Foliage Pop In - Turn it off - Content Creation - Unreal Engine Forums where it was suggested to edit consolevariables.ini - however, this has no effect at all for me.

How do I keep the value of 0 for foliage.MinimumScreenSize set, and have it work as I wish in the packaged version? I’m out of ideas, and I’d really like to be able to package it for testing as soon as possible – please help.

The scene shown on opening the level.

The scene as it should look, with foliage.MinimumScreenSize set to 0.

It’s solved - I’m putting the answer here in case anyone else has a similar issue.

For some reason, I’d been looking for a node that worked to execute that console command, but hadn’t been finding the ExecuteConsoleCommand node at all. Setting it up on EventBeginPlay works fine.

da563621ae490402b088de783a107b54bb8e747a.png

Sorry for the trouble!