Download

Keep Textures Pixelated?

Dear UE Community,

Epic released the 4.3 Preview today and alongside with that, they also released an Alpha Version (?) from the Paper2D Plugin. I am playing around with it right now and got some things done, but I noticed something, which kind of bugs me.

I have imported oldschool bitmaps from the SNES Game Super Metroid (educational purposes…yeh yeh…) and noticed, that UE4 loves to smoothen the texture. It no longer remains being this “pixelated” style, instead everything is smoothed and blured.

Is there a way to restore the “pixelated” original look from this rather tiny bitmap?

Greetings,

Maxunit

Double click on your texture in the content browser and set Filter to “Nearest”. See screenshot below:

TextureEditor.jpg

Thank you, Ehamloptiran,

I totally oversaw this option, will try it out asap :slight_smile:

EDIT:

That did the trick, thanks again.

Paper2D includes a shortcut in the context menu on texture assets called ‘configure for sprites’, which does that and IIRC sets it to uncompressed as well. The option needs to be renamed, since it’s only for retro sprites, but it might be useful for you.

Cheers,
Michael Noland

Cool thats good to know, I will keep that in mind for the future.