K2Node Error on package

Hey There,

I tried to make a package for my game and bumped into this error:

Error: Couldn't find parent type for 'K2Node_GetSequenceBinding' named 'UK2Node' in current module or any other module parsed so far.

The thing is I never created a custom node in my project. Here is my Build.cs:

// Fill out your copyright notice in the Description page of Project Settings.

using UnrealBuildTool;

public class XRoad : ModuleRules
	public XRoad(ReadOnlyTargetRules Target) : base(Target)
		PCHUsage = PCHUsageMode.UseExplicitOrSharedPCHs;
		PublicDependencyModuleNames.AddRange(new string[] { "Core",

		PrivateDependencyModuleNames.AddRange(new string[] {  });

		// Uncomment if you are using Slate UI
		// PrivateDependencyModuleNames.AddRange(new string[] { "Slate", "SlateCore" });
		// Uncomment if you are using online features
		// PrivateDependencyModuleNames.Add("OnlineSubsystem");

		// To include OnlineSubsystemSteam, add it to the plugins section in your uproject file with the Enabled attribute set to true

“DcxVehicle” and “citybuilding” are two differents plugins.

The only “custom” node existing in my project would be in the DcxVehicle plugin where I have an animation nodes.

Oh and my project work just fine in the editor, this error only appear while I try to package.


Hi! I have the same problem. Did you solve it?
I tried to add and remove some modules to the dependencies but I always get the same error. :\

Unfortunately, no. I made some research about it and noone seems to have a solution about it except not using K2Node, which is not really a solution.

I have solved it. Check link text if it can help.

I have solved my problems after some digging, thanks to Javiere answer.
I had some dependency to a standalone windows editor plugin called “cityBuilding” that I created, after removing them it worked perfectly.