Download

JPrinter, print images or textures in printer

JPrinter is a plugin allowing users print a .bmp, .jpg or .png to some printer with file location, also is allowing print Texture2D with pre-format to printer.

Current unreal engine version 4.22

Plugin available here: https://github.com/zkarmakun/JPrinter

Basic features:

  • Get primary printer name
  • Get List of all printers
  • print from file
  • print texture2D

Important notes:

  • Only for windows
  • For free!!!
  • If you use “print image” function, it will hijack your last printer settings (avoid the windows dialog boxes)
  • Known issue: weird colors when you print a Texture2D, change the texture resolution, sometimes this happen when an single pixel is lost on the resize process (windows bug)
  • Set your texture to RGBA like the image below (AFAIK we can´t re-compress a texture at runtime, is not allow by EULA)

If you want print a texture, this config is mandatory.

If your paper is set to None, then you print the pixel convertion to 361 DPI size!

printer.jpg

Quick test…

Summary
Hi forum!, after years I had sometime to update this project. there is no plan to port this into MacOs but it is working perfectly on windows.

Finally, I tested the plugin with almost 20 different printers (don´t ask how I obtained), including: epson, hp, samung and everything was fine.

For any issue or request, post please!

Thanks, man!! Didn’t test yet, but you’ll save me tons of time in a project!

Hey.

Thank you for making this :slight_smile:
I’m looking forward to use it. :smiley:

Thank you very much:D
I’m trying to write one plugin too, but meeing some problem.
You’ll save me a lot of time.

thank you for plugin, I going to use it in 4.18, is it still work and updated?

Printer Technical Support Customer Care Number [TABLE=“border: 0, cellpadding: 0, cellspacing: 0”]

1-855-242-6006

Thank you for plugin.
I want the update of 4.20!

Looking forward to update for 4.21!

Hi there!

Thanks for this @ZkarmaKun

Is this usable with 4.21? or will you port it soon?

I need this functionality and I could not find another solution.

Thanks!

Me too, I want use on my store system that’s I am building on UE4!

@Juangea @Estape sorry guys, I updated this to version 4.21, also I have edited my initial post, you will have the link directly to my Github.

Cheers!

@ZkarmaKun Thanks a lot!
It´s hard to update the plugin when a new UE4 version is out?

I mean, in general, if 4.22 goes out and we have to manually update the plugin, what do we have to do? Is it hard?

Thanks again!

@Juangea Tipically is not hard at all, probably you can copy and paste in your project and recompile, but it might require some changes, one never knows. It is mosly dependent on the unreal API

Cheers

Thank you very much @ZkarmaKun, I really appreciate!!! :slight_smile:

I got this two errors after put your plugin inside the project Plugin folder, also in engine Plugin folder. Any ideias? =S

I really tried recompile your plugin, but maybe is because my experience with c++ is low, so I was unable to compile… =/

@Estape sorry I have been busy these days, I haven’t tried yet. If you want to recompile you need 4.21 for now, copy and paste the plugin inside your new c++ project, regenerate your visual studio solution from your .uproject, then open it and click compile. Never try directly from the uproject, it will fail all the time, that feature is basically useless

i try to put it into a UE4 project
but when I generate visual project file it show me:

Running C:/Program Files/Epic Games/UE_4.21/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project=“D:/UE/temp/temp.uproject” -game -rocket -progress -log=“D:\UE emp/Saved/Logs/UnrealVersionSelector-2019.02.20-15.37.29.log”
Discovering modules, targets and source code for project…
While compiling D:\UE emp\Intermediate\Build\BuildRules empModuleRules.dll:
d:\UE emp\Plugins\JPrinter\Source\JPrinter\JPrinter.Build.cs(8,9) : error CS1729: ‘UnrealBuildTool.ModuleRules’ does not contain a constructor that takes 0 arguments
ERROR: UnrealBuildTool Exception: Unable to compile source files.

how to add it into my project?

I’m trying to get this to install, has anyone been able to get this to work? I’m getting ERROR: UnrealBuildTool Exception: Unable to compile source files.

Hi,
is it posible to use this plugin on unreal 4.22? I need a new feature that is only available on 4.22 and I will be great to be able to print.
Thank you.