Join Session over LAN

Using the MultiplayerShootout example, I can’t play over LAN. It simply doesn’t find the sessions?
Pretty sure some setting somewhere is blocking it, but I can’t figure out what.

Tried with opening the firewall on both PCs and the router at port 7777, as stated around here on other posts. Still doesn’t work…

I am not entirely sure how the UE4 LAN framework works, but I would recommend connecting to your listen server by using the ‘open IPaddress’ console command if nothing else works.

Given that they have blueprint for Creating and Joining sessions, with a boolean for LAN, it should work.
I can get it to work locally, launching several games on my computer and they find and connect to each other.

Host matches broadcast their session info to other machines on the LAN by sending packets to your LAN’s subnet. I would check to see that this broadcast packet is not getting blocked, and confirm that your machines are on the same subnet, which they probably would be if they are hooked into the same router.

See Unreal\Engine\Source\Runtime\Online\OnlineSubsystem\Private\LANBeacon.cpp::FLANSession::Host function


Also, just saw this at the top of LANBeacon.h:

#define LAN_ANNOUNCE_PORT 14001

So try opening up that port as well. Cheers

It seems like a hassle if you have to manually open several ports in order to play a game over LAN.

Routers gonna route. I’m curious if opening the port worked for you?

I haven’t had the possibility to test it yet, other guy left for the weekend.

gosh thats a long weekend… could you solve it? I am trying to connect from phone to PC via Wifi. My setup works with an adHoc network created on PC, but not with router’s. Is it a router setup issue?

1 Like

Did you ever find a solution?

Mine used to work with LAN onlinesubsystem NULL, but suddenly in 2020 it decided not to. Did you find a fix?

I haven’t, and I’m still looking. This guy supposedly has a solution that I’m trying to repeat: UE4: How to set up LAN-Multiplayer for Windows and Android | Squareys' Blog

So you’re saying you’ve got it working so that an android client can connect to an android server without manually entering the ip?

It looks like that was to patch UE 4.21
so I’m not sure if that’s the issue now.

I know it’s not the issue with 4.24.3 because when I ran the C++ to GetHostAddr (or whatever the function is called) then it actually returns my correct private LAN IP address.

However, Android still can’t Find Sessions run by PC for me,
but it turns out it CAN connect directly by IP address, but for some reason (and maybe this was just a fluke) it started working when I run the PC executable with command line args -nosteam -port 7777.

I don’t know if either of those args made the difference or if I just stopped being unlucky and the gremlins in my computer died off, but it works between android servers and android clients and also between PC servers and android clients. And between android servers and PC clients (though with REALLY bad network performance on the PC side).

Anyway I just hope you don’t do a ton of work only to find out that the problem is already fixed in a later version of UE, but maybe it’s not fixed so let me know what you find out.

In the past, on version 4.22-4.23 but for some reason 4.23 stopped finding sessions when running on Android and I never found out why. Maybe it’s my wifi router’s fault.
But for now I’m providing an option to search LAN sessions or input IP address so if the find sessions fails then they can at least type in the IP and join that way.