Jitter on attached meshes to player pawn

Hi, I’m running into an issue where static meshes attached to the player pawn are jittering during movement.
(The player pawn is a vehicle in which you drive, and if you sit in the driver’s seat, anything attached in the view will begin to jitter after moving for a short period of time)

I’ve tried attachment both by socket, and by just making it a child component of the player actor.

Physics and Collision is turned off for each individual component (as well as gravity for the entire project,) but the jitter still occurs after moving for a short while.

Everything is flagged as movable and not static as well.

Is this a known issue with attachment?
Any help is appreciated.

Do you have sub-stepping turned on? This might help with the jitter.

Just tried that out, and it didn’t seem to help at all.

Are there any other settings I should investigate?
Let me know if there’s any info I can provide that will help chase this down.


Could you post a quick video of this so I get a better idea of what type of jitter you mean. Is it jitter of the static mesh attached or the entire vehicle? I wouldn’t expect any jitter as the attached mesh should just inherit its position from the parent. It could very well be a bug so a video would help with giving me some ideas.

It’s just the static mesh that’s jittering, if the mesh is hidden, it’s clear the vehicle isn’t jittering at all.

Is there a way I can Pm you a video? I’m unable to post anything from the project in a public forum at this time. Thanks.

you can e-mail me at ori.cohen@epicgames.com

What happens if you turn collision off on the static mesh? It sounds like there might be some fighting between the two meshes

Hi ,

Which version of the editor are you currently using?

Hi, I’m on latest 4.4.3.

and let me clarify with some details since there’s been more investigation on this issue outside of this thread.

I stripped down the player pawn to just one static mesh component + a camera and can still repro the issue 100% in a single isolated test level.

I thought it might be the mesh itself, but after attaching any sort of mesh (just a test cube) near the camera and it jitters in flight.

I also tried shrinking the vehicle in scale which also didn’t help.

Let me know if there’s any more information that may help with this as I’m still stumped.


Hi ,

We were able to reproduce this in our default Flying Template. I have created TTP# 348435 in our tracking software and we will be looking into the issue further.

Thank you for the feedback.


Thanks for looking into this issue TJ, looking forward to a future fix.

Was this issue ever resolved? I’m having a similar issue in 4.6.

yup something got fixed in the engine that resolved this issue for me.

Hey TJ, I just moved up to 4.6.1 yesterday with my project and I’m having this exact same issue once again.

Would anything have changed from 4.5 to 4.6 that could have re-opened this bug? Are there any new settings in 4.6 that need to be checked to deal with this?

I’d be very thankful if you could look into this for me as it’s pretty critical to my project. Thanks!

the issue was fixed for me in 4.5… but I just moved to 4.6 the other day and it appears that it is broken again with 100% repro. (I’m commenting this under my claimed fix post in attempt to re-open this issue)

I don’t know of anything that was changed in 4.6 that would effect this.

What is your Motion Blur in the Post Process Volume set to? I don’t see any sort of blur/jitter effects in 4.6 as long as that value is zero.

Just to make sure it isn’t just your project, could you try to reproduce this in a new project like the Flying template?

Hey TJ, I just rolled the project back to 4.5, and all of the jitter issue completely went away.

We have motion blur globally disabled, but the issue isn’t a pixel jitter, it’s objects actually offsetting and dancing about. It’s definitely not a post problem. I’m 99% sure it’s the same issue we were seeing before when I first reported this bug in 4.4.3.

When I get some time this week I can try to repro it in a new project though just for a base case.

Hi ,

I still haven’t been able to repro this yet. Have you had time to make a small test project?

Hi ,

We haven’t heard back from you in a few days, so we are marking this post as resolved for tracking purposes. If you’re still experiencing this issue, please feel free to post back here with additional information and it will reopen the post.



I am still facing this in 4.7.6. I am going to make a small youtube video and post the link here

Hi, same here also on UE 4.7.6. It could be that I’m just doing it all wrong… For me the jitter also only on the mesh. Weird thing is that the server view on itself and the server(object-mesh) on the client view doesn’t jitter, at least it doesn’t seem like it does, where the client on itself and on the server’s view of the client(object-mesh) it jitters alot.