Download

Jagged Shadow?

Hi, new to UE 5 here. When I was playing around with Lights I noticed some of the shadow quality are very low and are jagged. Here is some screenshot of that


So far I tried to increase the light source radius to create a soft shadow but it didn’t solve anything. My speculation is it’s caused by Nanite due to the triangulations. Can someone tell me how to fix this, thanks!

I haven’t tried nanite yet. But I had this jagged shadow issue on one scene on regular meshes and solved it by enabling support for raytraced shadows in project settings.
That said also lumen hw raytracing has to be enabled for this to work I think.

having jagged shadows as well and enabling ray traced shadows / HW didn’t work

I noticed that in my scene too, i’m pretty sure there has to be a console comand to increase the quality / resolution of shadows.

These console commands should help:

For directional lights:
r.Shadow.Virtual.ResolutionLodBiasDirectional -4

For local lights:
r.Shadow.Virtual.ResolutionLodBiasLocal -4

1 Like