Download

Issues with VR rending since 4.20 (using DirectX)

So!

After updating 4.20 from the preview build to the release build, this happened:

https://forums.unrealengine.com/filedata/fetch?filedataid=146265&type=thumb

(Uncompressed version: https://i.imgur.com/wWCZhfT.jpg)

Whenever I start my game in VR a weird pattern is drawn over all game graphics. Even thumbnails are affected! To make it disappear I have to restart the editor.

The pattern looks a lot like the lens distortion UE applied to VR games.

The preview builds for 4.20 worked just fine, but I can’t get VR rendering to work since the official release.

I can get the pattern to disappear if I take a HighResScreenshot while not in VR. Upon starting the VR mode the pattern reappears though.

Today I discovered that this only happens when I use DirectX. Vulkan and OpenGL have their own problems though, so I can’t really use them. Past version of UE still work - right now I’m using 4.19. I’ve not found a way to redownload the preview builds.

Here are the things I’ve tried:

  • Reinstalling UE 4.20
  • Creating a brand new project
  • Updating my graphics card driver (I’m using an AMD R9 390)
  • Deleting my derived data cache (Which I hope I did correctly)
  • Creating a topic on Answerhub (heh)

Has anyone else experienced a similar issue? If there’s some clean way to reinstall UE, or if anyone has a list of things for me to try, then I’ll gladly do it.

I am completely open to all suggestions. All answers are appreciated! :slight_smile: