Issues with Steamworks

Hi, so I’m having some issues with Steamworks API. It’s working correctly, but it seems to be causing an issue with editor. I’m able to launch standalone games, but if I try to launch it via PIE, it says PIE failed to launch and entire editor crashes. I’m also unable to connect to my localhost dedicated server, although I’m able to connect to a listen server just fine. When disabling Steamworks, everything works normally again. I can’t seem to figure out what issue is here.

I’m using editor built from source off GitHub, I believe it’s version 4.9.2 (edit: nevermind, it’s 4.10). Also I’m not sure if it’s related, but when launching editor via Visual Studio debugger and trying to launch PIE, it asks to break around this line here.
TArray LevelBlueprints = Level->GetLevelBlueprints();
That is line 2280 of PlayLevel.cpp.

While this is mostly an inconvenience at most, it’d be great to be able to fix it. Any advice is greatly appreciated.

Edit: So if I launch PIE with number of players set to one, it works, but if I raise amount of players or enable running a dedicated server, it crashes.

Hi Jeezy,

Please and attach logs from project’s \Saved\Logs folder. It would also be useful to have information in Crash Reporter window if you get that, including Machine ID, so we can look it up here. Make sure you hit Send.

Are you using Steam SDK 1.32? That’s what we’re currently supporting.


There’s log, although I feel there might be some mixed information in there because I’ve also been having issues with editor crashing on nearly every successful compile but that’s least of my concerns. (even without Steamworks API)

It appears I’m using Steam SDK 1.35, I’ll attempt to switch to 1.32 ASAP and report back. Also is switching to 1.32 as simple a switching paths that my includes use?

Anyways, I’m not sure exactly what I’m supposed to be pulling out from crash reporter, but this is what I see.


Fatal error!

Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x00000148

UE4Editor-UnrealEd.dll!UEditorEngine::PlayInEditor() [e:\unreal engine source\unrealengine\engine\source\editor\unrealed\private\playlevel.cpp:2276]
UE4Editor-UnrealEd.dll!UEditorEngine::StartQueuedPlayMapRequest() [e:\unreal engine source\unrealengine\engine\source\editor\unrealed\private\playlevel.cpp:1047]
UE4Editor-UnrealEd.dll!UEditorEngine::Tick() [e:\unreal engine source\unrealengine\engine\source\editor\unrealed\private\editorengine.cpp:1244]
UE4Editor-UnrealEd.dll!UUnrealEdEngine::Tick() [e:\unreal engine source\unrealengine\engine\source\editor\unrealed\private\unrealedengine.cpp:361]
UE4Editor.exe!FEngineLoop::Tick() [e:\unreal engine source\unrealengine\engine\source\runtime\launch\private\launchengineloop.cpp:2427]
UE4Editor.exe!GuardedMain() [e:\unreal engine source\unrealengine\engine\source\runtime\launch\private\launch.cpp:142]
UE4Editor.exe!GuardedMainWrapper() [e:\unreal engine source\unrealengine\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
UE4Editor.exe!WinMain() [e:\unreal engine source\unrealengine\engine\source\runtime\launch\private\windows\launchwindows.cpp:200]
UE4Editor.exe!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264]

Thanks. There’s certainly a lot of logs here, some of which have a lot going on. I’ll sort through them to see if I can find anything useful.

info in Crash Reporter window, especially Machine ID, really helps us compare call stack between this and known issues. Did you hit Send? It doesn’t appear to have made it to us. Can you try once more, being sure to hit Send before closing anything?

Let me know what happens after switching back to 1.32. Yes, simply switching paths should be sufficient. There’s some documentation here that may be helpful:

Aside from Steam SDK version references, it should be up-to-date. 1.32 has been included with 4.9.2 binary, but I’m not certain about 4.10 Preview or GitHub builds. Make sure you replace any 1.35 .dlls with 1.32 version, if you changed those.

Yes I did hit Send before closing anything, anyways I did it again so hopefully it made it to you this time.
Changing include paths for SDK seems to be giving same result, and yes I’m pretty sure 1.32 was included with this build since I saw .dlls in there when setting it up. Going to try a couple more things, recompile, and then report back if I have any luck.

Edit: Maybe this screenshot could help out a bit.

So I ended up forking a slightly newer version of engine and recompiling it. Although it’s kind of weird, at first steam overlay wasn’t appearing in editor and only in packaged games, but after recompiling my project recently it has begun to come up in editor again.

On bright side, attempting to launch PIE no longer crashes entire editor, but it does still give failed to start error. This is one and only error I get in message log.

Warning TravelFailure: PendingNetGameCreateFailure, Reason for Failure: ‘SteamSockets: binding to port 0 failed (0)’. Shutting down PIE.

Can I see your project’s DefaultEngine.ini network settings? Does this occur in a new project as well, or only your current project?

It might be helpful for me to look at project, if you don’t mind uploading it somewhere for me. You can send me a link via PM on forums if you’d prefer to keep it private:

Here’s my DefaultEngine.ini DefaultEngine.ini -
I haven’t tried it with a new project, I’ll try that and let you know what happens. Also I’ve been told I’m not only one with dedicated server issue while using steam subsystem.
Anyway is there any specific part of project that would be helpful? It’d take me ages to upload entire 22gb folder and I don’t know where I would upload it either.

That’s fine. Let’s see if you’re able to reproduce it in a new project first. If you’re able, you can upload that someplace like Google Drive or Dropbox and share it with me.

And just so I’m clear, you tested this in a fresh install of engine? Was that also 4.10? If you’d like to try 4.10 official release, that was just pushed out today and would be most helpful for testing this. Thanks!

Hi Jeezy,

We haven’t heard back from you in a while, so I’m resolving this post for tracking purposes. If you were able to reproduce this in a new project or have any other information you can share with me, please feel free to respond and we’ll continue investigating. Thanks!

I have a problem.I can not find steamwork v 1.32,steamclient64.dll and tier0_s64.dll

C:\Program Files\Epic Games\4.8\Engine\Binaries\ThirdParty\Steamworks\Steamv132\Win64 by default.