Issues with displaying UTexture2D in Orthographic mode

Hi All,

I’m trying to use a UTexture2D that I have created using C++. So far it’s working besides the rendering. The texture is uneven as seen in the first link. However, when I zoom into the texture, it is correct. How do I get the black and white lines to appear uniformly regardless of the level of scale/zoom?

I have created my UTexture2D with these settings

dynamicCanvas->MipGenSettings = TextureMipGenSettings::TMGS_NoMipmaps;
dynamicCanvas->CompressionSettings = TextureCompressionSettings::TC_VectorDisplacementmap;
dynamicCanvas->SRGB = 0;
dynamicCanvas->Filter = TextureFilter::TF_Nearest;

Thank you for any help!