Issues of scene capturing using Vulkan

Hi Epic, @DanielW

Let me repost my question here:…ng-vulkan.html

So I’ve been trying the scene capturing using `USceneCaptureComponent2D and UTextureRenderTarget2D with Vulkan both on Windows & Linux in UE 4.26.

Is there any specific PostProcessSettings for Vulkan and Transparency capturing that I am supported to configure?

There are a couple of issues as follows:

(1) The captured image looks much darker than running with In-Editor/Standalone. I followed the settings in here:…pturer.cpp#L89 Specifically, I’m setting CaptureSource as SCS_SceneColorHDR/SCS_SceneColorHDRNoAlpha and TargetGamma as 2.2f

  1. Transparency material capturing looks not totally reflecting the art. What would be the recommended settings of USceneCaptureComponent2D & UTextureRenderTarget2D to have a photorealistic captured output?

(3) There are some ghost effects in the captured images.

It would be great if you could help with some guidelines.

This is the expected image of transparency rendering, which is captured from the Standalone-run window:

So by using CaptureSource as SCS_FinalColorLDR and applying the PostProcessSettings from the camera cache POV (PlayerCameraManager->GetCameraCachePOV()), the darkening issue is gone but the other two persists.