Download

Issues Getting Oculus Quest Project Packaging

I have used Unreal for other projects in the past. This is my first time attempting an Android build.
This is just an empty project with nothing in it but a floor and a light source.

So my problem is packaging the Android ASTC package. I get an error at the end that says that it failed on rungradle.bat

It appears that it could not determine the java version.

FAILURE: Build failed with an exception.
UATHelper: Packaging (Android (ASTC)): * What went wrong:
UATHelper: Packaging (Android (ASTC)): Could not determine java version from ‘12.0.1’.

I had just grabbed the latest version of JDK. Is anyone aware of which version I should be using?

I am building with android 19 and JDK v14b

I have tried both 12.0.1 and 11.0.3 with the same issue

I used Android Studio to setup my Android SDK and it complained about using NDK v19 so I downloaded v14 and got past the first hurdle. I had to download JDK separate because it is no longer included with the Android SDK as the oculus starter guide suggests. https://developer.oculus.com/documentation/quest/latest/concepts/unreal-quick-start-guide-quest/

Any advice?

For anyone that has had trouble getting it running. This tutorial worked for me:

[quote=“SuperFreq, post:2, topic:126843”]

For anyone that has had trouble getting it running. This tutorial worked for me:How to Build for Oculus Quest using Unreal Engine - YouTube

I still get the error with that youtube. I actually had to reinstall android after following that video. Something in those steps is not working for 4.22. I was able to go around a lot of the errors created by that video by reinstalling unreal engine, android, quest, and pretty much all software other than Windows. I believe it might be caused by how the user in that video instals Android.