Download

Issues changing drives

Good day everyone,

Was hoping to post something about what I am working on, however, my first post is on my problems shifting drives.

I originally installed the Epic Launcher onto a normal HDD, and subsequently downloaded the ADK and installed there (it took just over a week :p). After experiencing the wonderful speed inside the ADK opening and working on assets, I attempted to migrate the install to a recently cleared SSD to help with load times. However, despite my best efforts I cannot get the ADK to be recognized in the new launcher install on the other drive, it just keeps wanting to download all over again.

Has anyone else had this issue or have a solution to the problem?

Regards

Wodger

I just recently did that. Really I could do was back up the previously modded assets from *\ARKDevKit\Projects\ShooterGame\Content\Mods
then uninstall UE4 from the old drive and reinstall it to the new one, then move the files back to the new dev kit

I’m not 100% on the process, but it’s something along the lines of starting the download/install before having the files there, then either pausing or stopping the install, exit the launcher and then copy the files over and try the install again.

I think there’s a post on the forums here about someone moving their install and having it work, it’s extremely finicky as the launcher is poorly built. Try a search and see if you can find it.

-WM

Honestly, I just switched over to an SSD and it isn’t working much faster at all. Yes, the editor opens faster, But the CPU still has to compile all of the assets, so no matter how fast your load time is, the compile time is going to take just as long.

Yes.

Access is extremely fast as I’m using my new PCIe SSD on this machine, until I can use my workstation, but compiling shaders and cooking is a slower process by far as this only runs an i7 920 whereas my workstation runs two Xeon’s and there’s just no comparing the two.

So it really depends what aspect of the DevKit you’re trying to speed up.

-WM

So, after finding this post:

I went about trying to get the install to go in - what I did:

  1. Started the launcher with admin privileges (not sure if this will make a difference)
  2. Went into the Ark tab and clicked big red button “install”. Now you need to wait a little until it goes past the “please wait” which for me takes ages, then once it starts downloading, click the “x” next to the download bar and it will ask if your sure to cancel install - go ahead and OK that.
  3. The big red button now should have “resume”
  4. Copy the arkdevkit directories to the install directory - on mine it was E:\Epic Games\ARKDevKit, directories are “Engine” “Model and animation sources” and so on.
  5. At this point I closed the launcher and deleted the directory “icC9S” and the "$resumeData file - not sure if this made a difference either, but have a feeling it forces the launcher to check the install directory rather than go straight to download.
  6. Restart the Launcher (again with admin privileges)
  7. On the ark tab click “resume” and with any luck it should do what mind did which is to “install” and “verify”

Now this is what worked with me, I thought I had done this before except I didn’t remove the files in point 5. above, I tried all sorts, but this was what eventually worked.

If anyone else tries this method, please report back to let everyone know if it indeed works!

Tx Wodger.

P.s. Thanks go to WM above for leading me along the right path :slight_smile: - and agree about the launcher :stuck_out_tongue:

Thanks

I had tried something similar to this. However I did not delete the .lcC9S & $resumeData. It’s now verifying. Thanks for the guide.