Issue with precomputed sky light on a landscape

I’m experiencing problems with precomputed light on a landscape:

As you can see, there are visible seams right at the boundaries of the terrain segments (next screen is from the landscape mode with a terrain segment highlighted):

It happens only at this particular area, which is occluded by lots of static meshes (like a cave). It looks ok on the rest of the map and on the other maps as well (with identical settings):

I’ve also found out that this artifact is caused solely by sky light (turning it off fixes the issue). There are only a directional and a sky light on the map, both of them is stationary.

Here are the world lightmass settings:

Landscape light and lightmass settings:

Sky light settings:

I’ve tried tuning different settings, clearing all the cached lightmaps and rebuilding light with max quality, but this bug just won’t go away :frowning: Would really appreciate any thoughts on how to fix this.

Static Lighting Resolution must be a round number (int) , not a float.
Try that.