Issue with MoveToLocation not working in 4.11.1

Hey there,

Our team just updated to 4.11.1 and now all our AI-controlled characters have broken movement. It was working flawlessly in 4.10.4.

Here is the code that initiates movement, once the mouse clicks on a destination.

	//Execute the spending of ap for our action.
	if (GetAP()->Push(apSpend))
		HGDebug::Log("Moving unit!", LogUnit, false);

I have dug deeper into the code for MoveToLocation, tried it with all sorts of parameters, and movement still doesn’t work. My unit inherits from Character, my movement component inherits from CharacterMovement, and my UnitController inherits from AIController.

If I enable the gameplay debugger and select a move destination, I get the output you’ll see below. You will notice that the path following component has had its state changed to Moving, but it still doesn’t move. I have checked the walk speed and it is set to 640, so it definitely should have the capability to move. There is definitely a nav mesh bounds volume in the scene as well, so that is not the issue.

Any ideas? I have been looking into this issue all day and no solution has been found yet.