Issue with lights (build light)

Hi guys,

I’m kind of a newbie with this and I’m having some problems with the lights in the scene. All the lights are static (otherwise some wouldn’t work), and the build is only a preview, however in a production build the result is the same.

I would like to know why these lights aren’t calculated and why the light spread disappears. I’m posting screenshots so you can understand better the issues I’m dealing with.

This is before the build (or bake)

This is after.

I appreciate all the feedback I can get, so thanks :wink:

Did you try cranking up the light level and build the lighting? They look like they’re on. I think 4.11 has some big bugs in my tests.

I’m guessing either your lightmap resolution is too low, or the lightmap UV’s need to be reworked.

I tried all of that and the lightmap resolution is up to 512.

Regarding the lightmap UV’s it seems strange cause there are a lot of different objects and none of them calculates the light correctly.

However there is an error that happens and that constantly requires that I clear the lightmaps, but that only happens if I do two builds in a row. In mapcheck I get “WorldSettings_1 Maps need lighting rebuilt”, which I do. I clear the lightmaps and I build the lights again… and the problem disappears… until the next time :(.

One thing I noticed which may be a bug is when I had ambient occlusion on my entire scene was very dark. Do you have it on?

Yes I have it on, but it’s only at 0.3.

Less than this and it probably won’t calculate anything. But I tried it with 0.1 and the result was the same.

The thing that is bugging me is that it seems that the light isn’t baking correctly in the textures. The spotlights loses their highlights and subsequent shadows. I even increased the spotlights values because I was considering the dimming of the light in the bake, but it still doesn’t stick.

Turn off AO completely and try again? Can you post your Lightmass settings for people to see?


This is my current Lightmass settings.

I had to reduce the indirect bounces because the metalic grid and the light bouncing in it generated a red glow.


Hey guys,

This isn´t getting any better. It’s getting worse. I tried no occlusion, and it got eve worse. And the spotlights/lights aren’t baking. Is there a limit to the number of static spotlights in a scene?

And something strange happened. I gave this to a friend to create a build for Vive and with him the light bake worked.

Have you tried copying your scene to a new project? I’m not sure exactly how to do it at the moment because I’m not at my UE4 PC, but it seems like it might be a good solution if your friend was able to build the lighting without problem. There has to be some forum posts explaining how to do it.

I haven’t completed the migration, but I’ve copied the content and tried out some objects and the map check errors still continues and it seems that some of my objects aren’t building the shadows correctly.

I’ve managed to complete a correct light build by lowering the lightmap resolution of the objects, and tweaking with some properties like “indirect lighting smoothness” and bounces. May this have anything to do with my rig? I have an old I7 with 8 threads at 3.4Ghz and a 970 GTX.

I would to polish the shadows and the lights but since this is so unstable I’m reluctant.

maybe try upgrading to 4.11.2 if you haven’t already? it might be worth a shot

I think I would strip out all of the lights and put just one in and build the lighting, then add another and build. Once you have established it’s building okay try adding the rest.

It’s worth a try. I’ll get back to you with some results.

I guess it will work to a degree but what if I need more lights.

I don’t think there is a limit to static lights? Correct me if I’m wrong. Right now this should be about trouble shooting your scene then you can reach out to Epic for help once you hit the wall.

I tried it and it didn’t change anything.

However I tried something that I read in a different thread and it seemed to work - Texture Streaming Pool Over - World Creation - Unreal Engine Forums

Apparently the error was due to the texture pool size that by default is 1000. I increased it and it seemed to work. The behaviour is much more stable. Also I dabbled with the lighting static mesh resolutions.

It seems to work, and I hope this is the end of this problem.

Thank you for the feedback and the support, it was really helpful guys ;)!

I’ll leave with a preview of what I managed to get, and also could you help me with the light spread in the wall so that it doesn’t get so jagged.

The light build is in high.

The jaggies are caused by too low of a lightmap rez on the surface that is jaggie - bump it up.
Glad you sorted it out!

I thought so, but the resolution is 512.

I’m raising it but I really expected that 512 was more than enough. I’ll try production build and see what comes up.

If it’s a wall surface you may have to slice up the face into smaller bits rather than one large plane.