Issue with Lightning when turn on " Generate mesh distance fields "

when I turn on Generate mesh distance fields, I have some issue with my meshes:

Mesh Distance fields OFF


Mesh Distance fields ON


Is it possible to fix that? to get the same render than when it is off

Look up the doc pages on MDF, especially for foliage and trees. It appears to be darker mostly at the bottom of the leaves, which could partly be an AO problem. Open the tree in the mesh editor (right-click tree and select Edit ‘tree_label’) and try setting the distance field resolution higher by a value of 1 per change. Enable two-sided distance field. Also use “Full Precision UVs” and “High Precision Tangent Basis” in the Build Settings where those other settings are too.