Download

Issue with far shadows when using static lights and gpu ighmass

Hi everyone, I am wondering if anyone knows why the editor appears to be mipping/ruining the far shadows in this environment, I am using static lights and building it through gpu lightmass, but appears to be a editor/viewport issue rather then a lightmap issue, as seen in the screenshots I have increased the lightmaps to be very dense.

That’s an anti-aliasing thing, there’s a dark edge that’s smaller than a pixel on-screen and it’s trying to figure out how to render it, but needs more samples to make it look cleaner.

Thanks dude, will test it out soon and let everyone the results here.

So I’ve tried changing through the different anti aliasing methods as well as changing the sample amounts (though console command r.TemporalAASamples 4) even tried raising it but still having the same artifacts. There were small changes when switching through anti aliasing methods but still quite obvious. Is there no work around other then just increasing the thickness of the panel mesh/doing a heightmap or something. I have attached project rendering settings if it helps.

You could try supersampling, in your post process volume adjust the screen percentage to higher than 100% and it will render at a higher resolution and then scale it down which improves anti-aliasing.

Hi I managed to find a combination solution with what you told me and by forming the mesh roof and panels as one closed mesh and made sure the lightmaps were planar projected on so it was made of one shell. Thank you very much for your help!