Download

Issue with Distant Field Shadows

Hey everyone.

Currently trying to get Distant Field Shadows working. No matter what i do the DFS’s only extent a few feet from the Cascaded shadows. any ideas?

DFS’s disabled
eda49a79cc755dfcba179265e12f0f755e2d1cb8.jpeg

DFS’s enabled
8ffa43c79ed926571859b1763e4e26e7.jpg

Settings
93f82ac66f64a6a5aa9234885f6f04af9cc1d5a1.png

I think what’s happening is the trees don’t have a distance field representation. Check in Show->Visualize->MeshDistanceFields. Only things present in there can cast a shadow with RTDF shadows. Foliage defaults to not affecting distance fields because having grass represented can really kill performance. Enable ‘Affect Distance Field Lighting’ on the tree foliage type.

Alright, i enabled MeshDistanceFields in the Visualize tab, i had already enabled it on the foliage types i wanted. Still no shadows and its throwing this error, “Distant Field AO is disabled through scalability” which i’m assuming refers to the engine scalability settings, everything is on epic in there. Am i missing something?

Bump.

Anyone?

Daniel said you should enable Show->Visualize->MeshDistanceFields to see if the trees do have a correct distance field represetation. Once that is enabled you should see a black/white view. Post a screenshot of that here. If there is no white, then there is no distance field.

Based on your screenshot, I would say there is no distance field. I don’t know if its a bug, but I’ve noticed that once you enable distance field shadows, the regular CSM shadow distance is somehow modified a bit, that’s why you probably see that the shadow distance is slightly more once you enabled it, even though there are no distance fields in your scene.

I do not get a black and white view, but im assuming thats related to the error its throwing.

Heres with Visulize MeshDistanceFields enabled. 15853aae1fee56365a566f800f759f931c19a842.jpeg

Make your Engine Scalability Settings a bit higher to see them

If you are using foliage assets, make sure that “affect distance field lighting” is enable in the foliage options.

r.DistanceFieldAO 1
try this