Download

Issue with decal's Alpha texture

Hey,

When I use a texture with an alpha channel for a decal, I have an undesirable white/very reflective outline, in one case: when there are kind of lens flares activated in a level.
I tried to activate/disable almost every parameters about lights/post-processing, but nothing changed.
Same for the material proprieties.
But everything is okay for a surface material with translucence.

alpha.JPG

Any idea? :slight_smile:
Thanks!

I would check your original image file

This is quite common especially in the situation when using alphas/ transparencies. A good way that I know of how to get rid of this (if it is from your image file) is to just make a copy of the diffuse, paste it in as a new channel, and use a color overlay of white/adjust levels to complete white. Sometimes when you make a selection, and just use a brush to paint over it, there sometimes may be a small “feather effect” around it and this can cause exactly what you mentioned.

Hopefully that helps you and solves the issue :slight_smile:

The thing is, my texture is a totally black one, with just an alpha channel.
In this image :
up-left : color
up-right : alpha channel
down-left : the decal see from above
down-right : with a different angle, we can see a “reflecting edge”

00544ff5094ccf08349657ece224b32b3a7fe22f.jpeg

An other example.
I add a decal in a Blank new project, load the bush texture.
On left that’s OK, but on right, you can see a subtle white/bright outline around the leaves and branch, when the light source reflect is above the decal.

803fdd03fac29d1e1ebf12d6020cd959f35d646b.jpeg

I’d suggest you to save your Alpha texture as an RGB .tga file, and choose “Alpha” as a compression setting in UE4’s texture editor and “Preserve Edges” checked, just to be safe.

Thanks, but it’s the same result. :slight_smile:
I just discovered that the same thing happens in some of the UE4 projects (Reflections, for example).
e.JPG

Adjust this value on the decal’s material until you are satisfied with the results:

http://i1234.photobucket.com/albums/ff408/BrUnOXaVIeR/MaskO_zpsbxssoc7y.jpg~original

I can’t, it’s a decal so the material is set as Deferred Decal (can’t change the Opacity Mask value).

Hey, just ran into the same issue in 4.20 - is there any new solution for that? I found this: https://answers.unrealengine.com/que…on-metals.html - but changing the Metallic property is not a reliable workaround in most cases, unfortunately.
Opacity Mask Clip Value is still not available for deferred decals.

Update: I’ve found out that increasing the Opacity value in the material can fix this to some extent, so that might be a workaround. For example, multiplying the Opacity by 2 or greater value eliminates the white border - but larger values tend to produce artifacts, so still not a perfect solution.

Pad the color data.

Thanks, but the only thing that goes into Color input is a simple Vector parameter in my case. Basically I have a set of number & letter atlas textures as a simple black-white mask with color driven by this parameter.
I think that for now the multiplied Opacity workaround (I’ve updated my previous post for others if they face this issue and find this) should do the trick…

My bad, did not read your post thoroughly enough. Yeah, it is a bit problematic for decals and comes from the fact that metallic and non-metallic surface attributes are mixing in an unnatural way.

If the table surface roughness is 0 and decal roughness is 1, those grey alpha pixels will give a roughness between 0-1 which results in light reflecting different than both table and decal material roughness value.