Issue when building dedicated server

Hello unreal community!

I am trying to create a dedicated server build for our prototype game. I followed every step in this link:

But i get stuck on part 6. when I need to use the unrealfrontend to cook the game. I get the following error:

UE4Editor-Cmd.exe executable. Needs to be built first.

I build the UE4 source engine in development. same goes for my Uproject.
I also created a server target. But doesn’t seem to show in the configuration of my VS project even after I regenerated my VS project files.

Does anybody has a working tutorial on how to create a server executable or build one.

btw using 4.7.1 and also tried this in 4.6.1

Thanks in advance.

I’ve just recently deployed a Linux dedicated server on a remote hosting, so it is absolutely doable. I will try to help you with your problem.

First of all, you should try cooking your project from inside the editor using Package project instead of UnrealFrontend. The latter one is a bit trickier to start with. As for the configuration - can you post a picture of your available configurations? You should have Debug Server, Development Server amongst them.

These are the 3 configurations in my editor.

In my VS file i have:

  • DebugGame
  • DebugGame Editor
  • Development
  • Development Editor
  • Shipping

I do have Debug Server and Development Server but these are in the VS project Source engine from github.

I followed this link:

Created a server target. but even after a rebuild these settings do not show in either the VS or the editor.

Can you post your server target file? Are you sure you’ve replaced all of the “Game” occurencies with your own project’s name?

Have you actualy regenerated your project files or have you just rebuilt your project? To regenerate the files you need to right-click on your .uproject file and select “Generate Visual Studio project files”.


link text

I just changed the name of the project to ProjectName. Other than that is this the server target from the link. Its located in the source folder next to the other targets.

Yes i also regenerated the uproject. Just did it again and no server or debug server in my package settings or VS project.

I’m running out of ideas to be honest. Everything has to work. Just in case, your target is a C# file (.cs), right?

Yes it is a cs file. Yeah after a few days of retrying the tutorial and searching errors I also have no idea what I’m doing wrong. I do think my server target works because when using unrealfrontend he doesn’t complain about the server target.

Is there anything that you have to change in your VS files?
Or do you need to ad your own configuration in VS?

I haven’t given up on you, don’t worry, I’m just thinking of possible issues. I’m also going to record a tutorial on this topic somewhere in the nearest future.

Could you maybe go over the steps you took to build a server? I would really appreciate it, not only me but people having the same issue. thanks for the help so far :wink:

Thank you :slight_smile: in the meantime I’m going to keep trying. I will post a solution if I find it. A tutorial like that would help so many people :wink:

Hi guys,

I have the exact same issue, and I just realised that when I generate VS project files, it unlinks my new GamenameServer.Target.cs from the solution. Is this happening to you too ?

It could be a new starting point to solve this problem

Hy ,
Thanks for noticing. I have the same issue with the server target that disappears. Looking into this atm. I will post an answer when I find something

I looked at the shootergame example. I noticed there that their isn’t included in their VS even when rebuilding. You also can’t choose server in their VS configuration. So the tutorials is somewhat outdated.

That’s quite annoying… :confused:
I hope a staff member will be able to help us, but for now, I just don’t find a solution

I don’t know about you guys, but its getting disheartening knowing how good this engine really is to be stopped in development by this problem

I’m presuming you have gone through these links as I have without success

Maybe piinecone maybe able to create a video of these steps, there maybe something very small we are just missing and its causing all these issues.

Suggestion for Tutorial would be create a project from either the first person/third person/vehicle as these are the projects I’ve currently tried and make the dedicated server from wither of these.

Pausing the video for compiling I going to take as a given as this can take a fair amount of time.

Keep going peeps, we will get this working somehow and then we can enjoy this amazing engine.

I’m recording a tutorial this weekend. Perhaps this will help.

That would be most helpful, I really appreciate the time and effort.

Hi Allar,
I’m running 64Bit & yes there is a UE4Editor-Cmd.exe in the Binaries\Win64 folder.