Download

issue -emulatestereo and more

I’m wanting to come out UE4 in 3D using simple side-by-side, my understanding being that the command line “-emulatestereo” is for. It’s not happening on my end, tried various ways. I’ve tried on three different platforms, Mac 10.9.5, Windows 8.1 over Bootcamp, and on a PC running Windows 7, and still striking out, though for different reasons. The first two, Mac & Windows 8.1 (64-bit), Play brings up a Standalone player, I click ` for Console, type “-emulatestereo”, and don’t seen screen splitting in two for both cameras. Other commands like “Stat FPS” work fine. Note, under File, Packaging, Platforms, I see Windows 64-bit greyed out, so that might be suggesting limited functionality. Thanks for advising to that point. One the PC running Windows 7, when I download the Epic Games Launcher, an error window pops up, “The application was unable to launch correctly (0Xc000007b). Click okay…” Any idea why I would be able to load UE4 on this “3rd” machine? Is there a limit per license in play? Is it Windows 7? Just to be sure, I uninstalled the Launcher, deleted the installer, downloaded again, same deal.

Thanks, anxious to get 3d moving for demo, appreciate the timely response(s).

You need to run UE4 from the command-line & add -emulatestereo to the list of arguments, it isn’t an in-game console command, i.e from Terminal.app:
/Path/To/UE4Editor.app/Contents/MacOS/UE4Editor [/Path/To/Your.UProject] -game -emulatestereo

(Replace /Path/To with the actual path to UE4 and your .uproject).

Ah! Many thanks.

Hello. So, just getting around to being able to try this, getting “No such file or directory”. Here’s what I have pasted into Terminal:

/Applications/"Epic Games Launcher.app"/Contents/MacOS/UE4Editor [/Users/benjy/Desktop/VR_Demo_Mac/VR_Demo_Mac.uproject] -game -emulatestereo

I put the UE4 app in quotations, read I need to do that whenever a file has spaces, left that out for the uproject file, since it doesn’t. Now I haven’t packaged the game, this is just the uproject file, which my understanding is it should still launch a player. Since I have various volumes at the top directory level, is this enough for each path, or am I missing that?, e.g. “/Macintosh HD/Applications…” Thanks for checking my work and clarifying. If I could stay in Mac OS for this demo and not have to switch for the other items I need in that OS, that would be way preferable.

Thanks for your time.
Benjy

I’ve replied a few times here, wish I could delete these other replies to avoid confusion, but here goes with the latest. I tried a number of ways, none of them working. Replacing “/Path/To” with actual path to UE4 and my .uproject appears not so straightforward. The format you prescribe differs from what I get following instructions I got online about getting absolute path names in Mac OS, using info, Where and file name; and this yet differs from what I get when a senior Apple tech advised me on yet a third approach, that being to click-drag the app to Terminal window, and later the .uproject file. Note, I added the bit in between, according to your instructions, "/Content/MacOS/UE4Editor ". The following was copy pasted from Terminal after hitting Enter:

benjys-mac-pro:VR_Demo_Mac benjy$ /Applications/Epic\ Games\ Launcher.app /Contents/MacOS/UE4Editor [/Users/benjy/Desktop/VR_Demo_Mac_folder/VR_Demo_Mac.uproject] -game -emulatestereo
-bash: /Applications/Epic Games Launcher.app: is a directory
benjys-mac-pro:VR_Demo_Mac benjy$

Note, the backslashes. If you’re able to get -emulatestereo to work on Mac, I’d be curious what system it worked with. Not happening here. Many thanks for getting back, if at all possible, we’re closing in on a presentation, playback is looking way crisper on the Mac side than when I’m in Bootcamp/Windows 8.1, so I’d really prefer staying in Mac OS. Thanks, again.

Here’s the latest, I got a little help from a friend who knows a bit about Unix Shell commands, here’s the code that in Terminal allows me to launch the build, alas only in 2D:

open /Users/benjy/Desktop/MacNoEditor/“VR_Demo_mac.app”

Mac OS doesn’t require a pointer to first open the UE4 Launcher, the project file itself contains that pointer. We were missing the “open” command, and note project file names must have “.app” added. So, this works, but if I run:

open /Users/benjy/Desktop/MacNoEditor/“VR_Demo_mac.app” && -game && -emulatestereo

or simply

open /Users/benjy/Desktop/MacNoEditor/“VR_Demo_mac.app” && -emulatestereo

The game still launches, but not in stereo either way. The && between command lines says if first command line works, then move onto the second. And if I omit the &&:

open /Users/benjy/Desktop/MacNoEditor/“VR_Demo_mac.app” -emulatestereo

I get a Help message, indicating it’s not enough without the &&. In any event, it appears -emulatestereo is meaningless to Unix Shell. If anyone has any other ideas, I’m personally out of them. Many thanks.

You need to use the actual UE4Editor.app application bundle, the binary version can be found in /Users/Shared/UnrealEngine/{Version}/Engine/Binaries/Mac
(Where {Version} will be the version number of the engine you downloaded such as 4.6)

If you built the editor yourself in Xcode then it will be in the Engine/Binaries/Mac subfolder of your git checkout.

Sorry, but I’m unclear. Your post says to run in Terminal:

/Path/To/UE4Editor.app/Contents/MacOS/UE4Editor [/Path/To/Your.UProject] -game -emulatestereo

Here where you post the path:

/Users/Shared/UnrealEngine/{Version}/Engine/Binaries/Mac

…would this then look like so in Terminal?:

/Users/Shared/UnrealEngine/4.6.1/Engine/Binaries/Mac [/Path/To/My.UProject] -game -emulatestereo

So, my path isn’t to Epic Games Launcher, it’s to the UE4 Editor. Thanks for confirming I have this right.

Beyond this, I now have other questions regarding 3d output. I was able to edit the path in the shortcut on the Windows side to kick out SBS, but two issues. My 3D monitor is looking for full screen, on Windows Alt Enter is the command for maximizing the screen, which won’t cut it having the border of the window showing in SBS. I tried the command line -fullscreen, which did something, not sure what, whole screen went black, game never displayed, just touching the controller brought me back to the desktop, with Unreal Player still running. I need it to go full screen, but also send the player to a particular video out (monitor), if you can advise me.

I actually way prefer to be running this on the Mac side, even in Bootcamp Windows 8.1 the scene looks mushy compared. Of course, your above instruction are regarding Mac, so I’d like to keep pursuing that, but the issue of full frame and which display it sends to also applies to Mac.

Thanks.

The full path would be:
/Users/Shared/UnrealEngine/4.6.1/Engine/Binaries/Mac/UE4Editor.app/Contents/MacOS/UE4Editor [/Path/To/My.UProject] -game -emulatestereo

That’s great, will try this, much appreciated. About going full screen edge-to-edge, any idea how to invoke that command?

So, no such luck with that, and tried many variations. I’m out of ideas. Have you actually watched this work on your end on Mac? Which OS?

why the hell isn’t this just a flag in the editor? Epic are so fixated on HMD they’re totally ignoring plain old 3d displays.

Agreed. I have no exposure to the landscape, how this forum or whatever other mechanism even has a prayer of blipping the Epic radar about suggestions for improvements. This is the first response here since I first posted in February. I’ve ported back to Unity over this single issue, which has it’s own issues, not the 3D output, just the inferior lighting and general ease of use. What does it take?

It’s working…But its field of view is coming very high…can we change it?