Is this a bug? Landscape collision can't be turned off even if set to ignore everything

Please select what you are reporting on:

Creative

What Type of Bug are you experiencing?

World Building

Summary

So, in unreal engine 5.4,
just hit new map, open world, select the landscape, set the collision to NoCollision.
hit play, It will still have all the collisions.

Change it again from NoCollision to Custom, set to ignore everything there, it will still colide with everyting else.

To test the collision, I just added some things, like the thirdperson character template we can get from the engine, and the other was just a cube actor, and check simulate physicis, drag it up.
It will fall and hit the landscape, as well as our character.

I initially was trying to do it in the other way around, setting the pawn to ignore a new collision object channel and using this channel on the landscape, but it does not work.
So to test the landscape itself I did this test, and surprising enough it also doesn’t work.

I did more detalied steps here: Impossible to igonre Landscape collision without also ignoring "world static"?

but then I think this is just a bug no? Landscape complete ignores any configuration the collision channel

Steps to Reproduce

Create a new level
select open world
select landscape
set the collision profile to Custom
Ignore everything in the collision
add a default cube actor
select simulate physics
move the cube up
hit play, cube falls, but collision still there, it hits the landscape.

Add a new object type at the project settings > collision, name it “LandscapeB”.
In either a pawn like a default third person character blue print, or any other actor, like the cube that was just added, select its collision profile, set to custom, set to ignore LandscapeB
Hit play, it will still colide, even with the landscape collision set to ignore all and with the new object type, it still colides with everything

Expected Result

Adding a new object type to the landscape, and ignoring this object type in any other place should make it pass trough the landscape
Or at least setting the ladscape to have not collision at all should do something

Observed Result

Landscape still have collision with anything

Platform(s)

Platform: Windows 11 (23H2) [10.0.22631.3593] (x86_64)
Version: 5.4.1-33305029+++UE5+Release-5.4