Is there any way to improve volumetric light leaving trails on fast moving lights?

According to the volumetric fog thread:

Temporal Reprojection

The volume textures used by Volumetric
Fog are relatively low resolution and
aligned to the camera frustum.
Volumetric Fog uses a heavy temporal
reprojection filter with a different
sub-voxel jitter each frame to smooth
out the aliasing. As a side effect,
fast changing lights like flashlights
and muzzle flashes leave lighting
trails. Disable volumetric fog
contribution on these lights with
‘Volumetric Scattering Intensity’ set
to 0.

Besides setting it to 0 is there any other way (even if it means changing some values on the engine’s source code) to increase the update frequency to minimize the trails?

I would also like a solution to this. there may be some console command to disable the taa blur?

You have the command r.VolumetricFog.TemporalReprojection 0 which will disable the trail, but you gain other issues, so it’s up to you which one you use.


I’ve answered the question :slight_smile:

theres the answer i was in search of… now into the realm of everything else it breaks…
thanks for the quick answer on console command!! upvoted

you Made my day Bro! it works!

Glad it helped :slight_smile: