Is there any way to avoid this? Some material is darker

Can’t understand what i’m doing wrong… They are same walls i mean both have same first and second UV Channel and this is what is happenening. Does this have anything with lightning or? I tried to search everywhere and can’t find it :frowning:

I noticed that it’s something with light source (Directional Light) is there any options for that? O.o

reimport the meshes and recalculate the normals

Tried m8 already that… I even delete the meshes and reimport them again… Her’s the deal how i noticed it’s only on backside O.o. They are 2 meshes but clones… How the hell that can happen? O.o

can i see your mat?

I’m using Exterior from Realistic rendering, i also tried double sided… Doesn’t work…

Posted m8 below…

Sorry but I can’t detect anything :frowning:

Np m8 maybe someone will help… :wink: ;)… Thnx for help anyway :slight_smile:

Hey Javca,

This is a result of the pieces being rendered on different threads when lightmass does it’s light bake. There are ways to completely get rid of this, ways to hide it, and ways to help easy the problem. I’ll give you all three. :slight_smile:

  1. To completely get rid of this the meshes would need to be a part of the same static mesh rather than more broken up modular pieces. This would bake that single mesh on a single thread without the shadow seams.

  2. Use other meshes like a column or some other static mesh to hide the seam.

  3. Modular Asset Lighting Problem - Rendering - Unreal Engine Forums

This forums post goes in detail about getting rid of the seams. You can ignore the parts about using grid snap for the lightmap. Not really needed.

The key things to adjust are two settings in the lightmass tab of World Settings (Toolbar > Settings > World Settings). Adjusting the Indirect Lighting Smoothness to around 0.6 and the Indirect Lighting Quality to 2 or higher (this part will increase light build times, start with 2 and move up if you need to test) will help with this. It won’t get rid of the seam entirely, but it’ll help smooth out the artifact you’re seeing.

Also, keep an eye on this Wiki page as this is one of the more common questions with light builds. I’m in the process of setting up some examples and getting a section up there. For right now, the forums post linked above houses all the information you should need to get this smoothed out.

I hope this helps! :slight_smile:

Is this gonna be fixed or something like that?
Because I think lighting should be determined and predictable.

There may be improvements as time goes on but these are the correct approaches to reduce seams or get rid of seams entirely at the moment.

Ty m8… somehow the whole situation is slightly better after i reimported the whole scene. Around 150 mesehs. After i finish with all i will try to play with light ty very much for that :slight_smile: