Download

Is there any solution to Volumetric Lightmap leaks?

Hi,

I’ve been playing with Volumetric Lightmaps inside UE4, but I have very hard time believing current solution can be used in production successfully. Even with very high volumetric lightmap voxel densities, far beyond what would be feasible for real game, they seem to leak pretty badly in high contrast scenarios. The scenarios I am talking about is for example a small house in a sunny environment, with big exposure difference between exterior and interior. Even if I place importance volume around the house interior, and crank up lightmap voxel density really high, voxels near the walls still get interpolated with the ones outside, resulting in any movable actor which gets close to the wall starting to glow. In fact the denser the lightmap is, the sharper the glow line is and the more problematic it becomes.

I was wondering if anyone ever figured a solution to this?

One thing I was thinking of would be something like “Local volumetric lightmap”. A box volume one would add to their map, which would calculate indirect lighting volume locally, inside the box, but would not interpolate with any volume lightmap samples outside of the box. At the same time, it would work as a global volume lightmap exclusion volume, so global volumetric lightmap would not create samples where the local volumetric lightmap box is. It makes perfect sense to me, so I feel like something like this already exists, and perhaps I just don’t know where it is/how to enable it?

Thanks in advance.

Anyone?

I am just really interested in what is the common workflow to handle indirect illumination on movable actors inside interior spaces which are separated by walls from exterior spaces of significantly different exposure.

Basically, so far I am failing to find a way how to prevent movable actor from glowing near walls when inside of interiors due to interior samples being interpolated with exterior samples of significantly different intensity.

There really isn’t anyone else who encountered this problem?

Oh, that’s unfortunate. I guess the search for workaround continues. Thank you very much for the answer non the less :slight_smile: