Is there a workaround DX12's crashes?


So I tried to import an .fbx to my blank project, but I can’t do it because DirectX 12 keeps crashing. I even tried switching to DirectX 11 in project settings, but to no success. I’m trying to launch the project, using Vulkan instead, see if it works. I’ll update the post with the result.

EDIT: Vulkan crashes as well, might be an error in the .fbx at this point.

EDIT 2: Just tried to import an old .fbx, which used to work flawlessly in 4.23.1 - also caused a crash.

EDIT 3: Importing the same .fbx model in UE 4.23.1 works flawlessly.

My question is, as the title says, since DX12 is still in beta and things like that can happen, is there a way to force DX12 not to load at all (or something like that) so it doesn’t cause a crash, until the bug is fixed?

If it’s crashing when using Vulkan or rollback to DX11, then it’s not DX12…unless DX12 somehow polluted the .fbx file. When is it crashing, at what point during load? I’ve had problems trying to re-open levels I was working in, but not creating a new level (always loads fast, whereas the pre-saved levels crash about halfway or almost finished loading). When I checked a log file of one of the crashes, there were a few errors regarding SSD (screen space denoising). Did you check those log files?


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.


It always crashes at the same point. Probably a specific file, but I can’t tell which one. No, I did not check the logs, where can I find them?

Go in the specific project’s (the one you were opening when it crashed) Saved folder, and then the Logs folder. Double click log files and they’ll open in Notepad or similar application. I found errors at the last part of the list, but there’s also a part of the list showing memory usage at the time of the load.

Checked the log, it shows an error about the renderer, followed up with what I aready get as a callstack in the bug reporter. Thing is, the error occurs while compiling the shaders for one of the skeletal meshes.

What’s it say in particular? or is it simply ‘error compiling skeletal mesh’ without any detail?

[2019.12.20-16.58.39:078][326]LogWindows: Error: Fatal error: [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/RenderCore/Private/RenderingThread.cpp] [Line: 853]

[2019.12.20-16.58.39:078][326]LogWindows: Error: Rendering thread exception:

[2019.12.20-16.58.39:078][326]LogWindows: Error: Assertion failed: Resource [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/D3D12RHI/Private/D3D12UniformBuffer.cpp] [Line: 106]

After doing a search of “Rendering thread exception” regarding DX12, I found an article that may help in identifying if it’s a video memory problem. It has instructions on how to do a trace of the GPU’s memory usage to see if there’s a problem, specifically one of the GPU overcommitting memory. I also noticed in a forum of The Division 2 earlier this year that a ton of cases of crashing were reported when enabling DX12 in the graphics options for the game. Crashes also occurred using DX11, as reported in the forum regarding Division 1 and 2. I think you’re encountering a memory issue, and it’s happening most likely as a result of the skeletal mesh referenced in the log. Need to go through a list of potential memory limitations that the mesh in question are/is probably breaking.

GPUview memory trace instructions