Download

Is there a way to exclude STATIC lights from volumetric fog?

Hey all.

I’ve been able to exclude stationary lights from the volumetric fog by setting the volumetric scattering intensity to 0. But this value is not available in static mode… I have a few static lights for faking GI, and saving performances.

Is there a way to trick the engine?

Thanks in advance.

Pierre

Unfortunately since the Volumetric Scattering Intensity is grayed out once the light is set to Static, there’s no obvious way other than disabling the static contribution to Volumetric Fog altogether in the Exponential Height Fog.

There’s one thing you could try if you want to rebake. You can force a Static light to bake with a IES profile by setting the light to Stationary, assigning the IES image, and then switch the light back to Static. You could try that with the Volumetric Scattering Intensity and see if that carries over. I’ve never tried that myself, but have wanted to disable fog from certain baked lights in the past.

I’ll try IES but I fear it will not do the trick.

Already tried to set the light to stationnary, put the Vol Stcat intensity to 0, it stays on 0 when I set back to static but doesn’t take care of this setting when I rebake.

It’s a bit of a bummer, I set my fake GI lights to stationnary even if ther is absolutely no reason to do so, except for this volumetric fog limitation.

By the way I have A LOT of weird things with Vol Fog in 4.18. Is there some improvements with 4.20 ?

The IES profile wasn’t an option. I was just using it as a workaround example, but since you’ve already tried the switch then I’m not sure.

You could use Stationary Lights and just be mindful of their influence radius. You could disable Inverse Square Falloff to get more out of the radius, and set their view distance to be pretty low

There is just single volumetric lightmap. Same is used for movable objects and volumetrics. After bake volume don’t have any information of static light actors anymore. It’s just baked light at that point.

I will try to dig this way.

if any dev see my post, is this aa engine limitation it is technicaly impossible, or the option is just not yet available? For I understand what Kalle_H explain, but I would like to know if it’s an actual limitation of the technics behind VolFog.

It’s technical limitation. You would need two different Volumetrics light maps to make this work.